FIX: If you set the ATA_FLAGS_48BIT_COMMAND ATA flag, the returned PreviousTaskFile member is incorrect in Windows Server 2003 or in Windows XP (898439)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

You can use the IOCTL_ATA_PASS_THROUGH structure or the IOCTL_ATA_PASS_THROUGH_DIRECT structure to send raw ATA commands to disk drives in a program. The ATA_FLAGS_48BIT_COMMAND ATA flag is introduced to enable 48-bit Logical Block Addressing (LBA) support in these structures.

However, if you set the ATA_FLAGS_48BIT_COMMAND ATA flag in these structures, the returned PreviousTaskFile member in the ATA_PASS_THROUGH_DIRECT structure or in the ATA_PASS_THROUGH_EX structure is incorrect in Microsoft Windows Server 2003 or in Microsoft Windows XP.

CAUSE

This problem occurs because of a bug in the Atapi.sys file. The bug causes the PreviousTaskFile member to be populated with incorrect data.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites You must have Windows Server 2003 Service Pack 1 (SP1) installed to apply this hotfix. Restart requirement You must restart the computer after you apply this hotfix. Hotfix replacement information This hotfix does not replace any other hotfixes. File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, x86-based versions with Service Pack 1
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   06-Jul-2005  00:38  5.2.3790.2481  95,744  Atapi.sys
Microsoft Windows Server 2003, Itanium-based versions with Service Pack 1
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   05-Jul-2005  11:39  5.2.3790.2481  309,248  Atapi.sys
Microsoft Windows Server 2003, x64-based versions
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   05-Jul-2005  11:39  5.2.3790.2481  148,480  Atapi.sys

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites You must have Windows XP Service Pack 2 (SP2) installed to apply this hotfix. Restart requirement You must restart the computer after you apply this hotfix. Hotfix replacement information This hotfix does not replace any other hotfixes. File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows XP, x86-based versions with Service Pack 2
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   05-Jul-2005  23:45  5.1.2600.2714  95,616  Atapi.sys

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix KB898439 kbAudITPRO kbAudOEM kbAudDeveloper