When you try to install Live Communications Server 2003, you receive the "Error 1920 Service RtcSrv (RtcSrv) failed to start" error message (898149)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2003

SYMPTOMS

When you try to install Microsoft Office Live Communications Server 2003, you may experience the following symptoms:
  • When the Live Communications Server Setup Wizard tries to start the Live Communications Server services, you receive the following error message:
    Error 1920. Service RtcSrv (RtcSrv) failed to start.
    Verify that you have sufficient privileges to start system services.
    If you click Retry, you receive this error message again. If you click Cancel, the Live Communications Server Setup Wizard rolls back the Live Communications Server installation.
  • One or more of the following events may be logged in the Application event log:

    Event ID 14344Event Type: Error
    Event Source: Live Communications User Services
    Event Category: (1006)
    Event ID: 14344
    Date: date
    Time: time
    User: N/A
    Computer: servername
    Description: 80004005 Unspecified error Event ID 16417Event Type: Error
    Event Source: Live Communications User Services
    Event Category: (1006)
    Event ID: 16417
    Date: date
    Time: time
    User: N/A
    Computer: servername
    Description: 80004005 Unspecified error Event ID 20482Event Type: Error
    Event Source: Live Communications User Services
    Event Category: (1006)
    Event ID: 20482
    Date: date
    Time: time
    User: N/A
    Computer: servername
    Description: Server could not register for notifications for configuration changes for the class MSFT_SIPESGlobalRegistrarSetting from the WMI Provider.Event ID 7Event Type: Error
    Event Source: Live Communications User Services
    Event Category: (1006)
    Event ID: 7
    Date: date
    Time: time
    User: N/A
    Computer: servername
    Description: Initialize failure. Failed to initialize the WMI configuration.Event ID 16415Event Type: Error
    Event Source: Live Communications User Services
    Event Category: (1000)
    Event ID: 16415
    Date: date
    Time: time
    User: N/A
    Computer: servername
    Description: Unable to initialize the registration component, error code is:0xc0700007 (Initialize failure. Failed to initialize the WMI configuration.). The service has to stop.

CAUSE

This issue may occur if one or more of the following conditions are true:
  • You try to install Live Communications Server 2003 on a Microsoft Windows Server 2003-based computer that has the Microsoft TCP/IP version 6 (IPv6) protocol installed.
  • Multiple entries exist in the CN=RTC Service container in the Active Directory directory service.
  • You try to install Live Communications Server 2003 on a Windows Server 2003-based virtual machine that is running in VMWare GSX Server version 2.5.

    Note Live Communications Server 2003 is not currently supported on VMware GSX Server.

RESOLUTION

To resolve this issue, use one or both the following methods depending on your situation.

Method 1: Remove the IPv6 protocol

Remove the IPv6 protocol from the Windows Server 2003-based computer on which you want to install Live Communications Server 2003. To do this, follow these steps.
  1. Click Start, click Run, type ncpa.cpl, and then click OK.
  2. Right-click the local area connection, and then click Properties.
  3. On the General tab, right-click Microsoft TCP/IP version 6, and then click Uninstall.
  4. When you receive the following message, click Yes:Uninstalling a component removes it from all network connections. Are you sure you want to uninstall Microsoft TCP/IP version 6?
  5. If you are prompted to restart the computer, click Yes.

Method 2: Remove entries from the CN=RTC Service container

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

Remove any additional entries from the CN=RTC Service container in Active Directory. Only one entry should exist in this container. To do this, follow these steps:
  1. Quit the Live Communications Server 2003 Setup program if it is running.
  2. Start the ADSI Edit tool. To do this, click Start, click Run, type adsiedit.msc, and then click OK.

    Note ADSI Edit is included with Microsoft Windows Support Tools. To install Windows Support Tools, double-click SUPTOOLS.MSI in the Support\Tools folder on the Windows Server 2003 CD. Or, double-click Setup.exe in the Support\Tools folder on the Microsoft Windows 2000 Server CD or on the Windows 2000 Advanced Server CD.
  3. Expand Domain [domaincontrollername.domainname.com].
  4. Expand DC=domainname,DC=com, expand CN=System, expand CN=Microsoft, and then click CN=RTC Service.
  5. View the objects in the right pane.

    There must only be one CN=Global Settings object. If more than one CN=Global Settings object exists, right-click the additional CN=Global Settings object, and then click Delete.
  6. Click Yes when you are prompted to delete this object.
  7. Follow steps 5 and 6 to remove all the additional CN=Global Settings objects. Make sure to leave one CN=Global Settings object.
  8. Quit ADSI Edit, and then restart the Live Communications Server Setup program.

MORE INFORMATION

For more information about how to deploy Live Communications Server 2003, see the Live Communications Server Deployment Resources. To obtain the Live Communications Server Deployment Resources, visit the following Microsoft Web site: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:4/29/2005
Keywords:kbDeployment kbtshoot kbprb KB898149 kbAudITPRO