A program that uses a remote access PPP connection to a Windows Server 2003-based computer is disconnected when the user logs off (897040)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Web Edition

Windows SE:153606Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

A program that uses a remote access Point-to-Point Protocol (PPP) connection to a Windows Server 2003-based computer is disconnected when the user logs off. After the user logs off, the user cannot log back on.

CAUSE

This problem may occur when software that uses a Remote Access Service PPP connection runs a service in the context of the Local System account. The problem occurs because remote access connections automatically disconnect when a user logs off from a remote access client. The default behavior is to disconnect remote access sessions that are associated with the logged on user and with the Local System account.
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, follow these steps:
  1. Run the service as a different account that has local Administrator rights instead of as the Local System account.
  2. Enable the KeepRasConnections key in the registry. To enable the KeepRasConnections key, follow these steps:
    1. Start Registry Editor.
    2. Locate and then click the following key in the registry:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

    3. On the Edit menu, click Add Value, and then add the following registry value:
      Value Name: KeepRasConnections
      Data Type: REG_SZ
      Value: 1
      Default Value: 0 (disabled)
    4. Quit Registry Editor.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Windows Server 2003 Service Pack 1 (SP1) installed.

Note Service Pack 1 is included in the x64-based and Itanium-based versions of Windows Server 2003.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, x86-based versions
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   21-Apr-2005  23:01  5.2.3790.314   1,192,448  Msgina.dll
   21-Apr-2005  23:01  5.2.3790.314     235,008  Rasapi32.dll
   21-Apr-2005  23:23  5.2.3790.314     540,672  Winlogon.exe
   21-Apr-2005  00:43  5.2.3790.314      59,392  Ws03res.dll
   22-Apr-2005  00:06  5.2.3790.2426    449,536  Licdll.dll
   21-Apr-2005  22:05  5.2.3790.2426  1,211,904  Msgina.dll
   21-Apr-2005  22:05  5.2.3790.2426    245,248  Rasapi32.dll
   21-Apr-2005  18:19  5.2.3790.2426    508,928  Winlogon.exe
Windows Server 2003, Itanium-based versions
   Date         Time   Version             Size  File name   Platform
   ------------------------------------------------------------------
   22-Apr-2005  00:06  5.2.3790.314   1,418,752  Msgina.dll     IA-64
   22-Apr-2005  00:06  5.2.3790.314     609,280  Rasapi32.dll   IA-64
   22-Apr-2005  00:06  5.2.3790.314     639,488  Winlogon.exe   IA-64
   22-Apr-2005  00:06  5.2.3790.314      58,880  Ws03res.dll    IA-64
   22-Apr-2005  00:06  5.2.3790.314   1,192,448  Wmsgina.dll      x86
   22-Apr-2005  00:06  5.2.3790.314     235,008  Wrasapi32.dll    x86
   22-Apr-2005  00:06  5.2.3790.314      59,392  Wws03res.dll     x86
   22-Apr-2005  00:06  5.2.3790.2426  1,465,856  Msgina.dll     IA-64
   22-Apr-2005  00:06  5.2.3790.2426    647,680  Rasapi32.dll   IA-64
   22-Apr-2005  00:06  5.2.3790.2426    680,448  Winlogon.exe   IA-64
   22-Apr-2005  00:06  5.2.3790.2426  1,211,904  Wmsgina.dll      x86
   22-Apr-2005  00:06  5.2.3790.2426    245,248  Wrasapi32.dll    x86
Windows Server 2003, x64-based versions
   Date         Time   Version             Size  File name   Platform
   ------------------------------------------------------------------
   22-Apr-2005  00:06  5.2.3790.2426    736,256  Licdll.dll       x64
   22-Apr-2005  00:06  5.2.3790.2426  1,193,472  Msgina.dll       x64
   22-Apr-2005  00:06  5.2.3790.2426    419,840  Rasapi32.dll     x64
   22-Apr-2005  00:06  5.2.3790.2426    922,112  Winlogon.exe     x64
   22-Apr-2005  00:06  5.2.3790.2426  1,211,904  Wmsgina.dll      x86
   22-Apr-2005  00:06  5.2.3790.2426    245,248  Wrasapi32.dll    x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbQFE kbHotfixServer KB897040 kbAudITPRO