The Wireless Link icon does not appear in the notification area and the "Send files to another computer" icon does not appear on the desktop when you try to connect an infrared device to a computer that is running Windows XP Service Pack 2 (896984)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional

SYMPTOMS

You log on to a Microsoft Windows XP Service Pack 2 (SP2)-based computer. When you try to connect an infrared device to the infrared port of the computer, you experience the following symptoms:
  • The Wireless Link icon is not displayed in the notification area at the far right of the taskbar.
  • The Send files to another computer icon does not appear on the desktop.
Therefore, you cannot connect the infrared device to the computer.

CAUSE

This problem occurs if the following conditions are true:
  • You log on to Windows XP SP2 by using an account that has limited rights. For example, you log on to Windows XP SP2 as a user who is a member of the Domain Users group.
  • An administrator has not logged on to the computer after the Setup program has finished the installation of Windows XP SP2.
This problem occurs because of a change in Windows XP SP2 that requires certain system-wide registry keys to be created for the icons to appear. If you log on to the computer as a user who has a limited user account after Windows XP SP2 is installed, you do not have the required permissions to create these registry keys.

These registry keys are created when an administrator logs on for the first time after the installation of Windows XP SP2. This enables the icons for all users.

Note If you log on to the computer after an administrator logs on, the infrared icons appear.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP SP2 installed to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   ---------------------------------------------------------
   21-Apr-2005  00:54  5.1.2600.2659     151,552  Irftp.exe      
   21-Apr-2005  03:59  5.1.2600.2659      28,160  Irmon.dll  

WORKAROUND

To work around this problem, follow these steps:
  1. After the Setup program finishes the installation of Windows XP SP2, log on to the computer by using an account that has administrative rights.
  2. Log off the computer, and then log on to the computer as a user who has a limited user account.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix KB896984 kbAudEndUser kbAudITPRO