The computer stops responding during Text mode Setup if you try to install Microsoft Windows Server 2003 (896900)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

If you try to install Microsoft Windows Server 2003, the computer stops responding (hang). This symptom occurs during the early part of Text mode Setup, and immediately after the following message disappears: Press F2 to run Automated System Recovery (ASR)

CAUSE

This problem may occur because of a bug check error in HalpFindACPIT that occurs early in the startup process. The error occurs because Setup incorrectly calculates the number of pages that are spanned by the ACPI differentiated system description table (DSDT). In an ACPI BIOS, the DSDT contains the Differentiated Definition Block. This block supplies the implementation and configuration information about the base computer system. The operating system always inserts the DSDT information into the ACPI Namespace at system boot time, and never removes the DSDT information.

RESOLUTION

To resolve this problem, follow these steps:
  1. Create a shared resource to distribute Windows Server 2003.
  2. Replace the existing files on the shared resource with the files that are included in this hotfix. For more information about how to integrate software updates into the Windows installation source files, click the following article number to view the article in the Microsoft Knowledge Base:

    828930 How to integrate software updates into your Windows installation source files

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-May-2005  03:01  5.2.3790.2439     116,736  Halaacpi.dll     
   06-May-2005  03:01  5.2.3790.2439      82,944  Halacpi.dll      
   06-May-2005  03:01  5.2.3790.2439     118,272  Halmacpi.dll     
   06-May-2005  03:02                    298,096  Setupldr.bin
   06-May-2005  03:02  5.2.3790.2439     278,016  Setupldr.exe     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbQFE kbHotfixServer KB896900 kbAudOEM