You may receive an "Invalid price" error message when you save your changes to an opportunity after you add a new product to that opportunity in Microsoft CRM 1.2 (896676)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

SYMPTOMS

When you save your changes to an opportunity after you add a new product to that opportunity in Microsoft Business Solutions CRM 1.2, you may experience both the following symptoms:
  • You receive the following error message in the Opportunity: Product dialog box:
    Invalid Price
  • You receive the following error message on the Information page of the Opportunity dialog box:
    An error occurred during the pricing of a detail line item.

CAUSE

This problem occurs if you try to add a product that has a price of zero ($0.00), where $ is your currency symbol. For example, this problem occurs if you try to add a product that has the following values configured.
Box nameValue
List Price ($)0
Standard Cost ($)0
Current Cost ($)0

RESOLUTION

Microsoft CRM has a fix for this problem that is part of a cumulative update. The cumulative update information is described in the following Microsoft Knowledge Base article:

904435 Update Rollup 2 is available for Microsoft CRM 1.2

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft product updates, see the following articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbMBSMigrate kbQFE kbHotfixServer KB896676 kbAudDeveloper