Users may be able to postpone software update installations beyond the configured time on Systems Management Server 2003 client computers (896611)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

Consider the following scenario:
  • You try to distribute a software update to Microsoft Systems Management Server (SMS) 2003 client computers by using the Distribute Software Updates Wizard.
  • You configure the Allow users to postpone installation setting on the Configure Agent Settings page to let users postpone the installation of the software update for a specified time.
In this scenario, SMS 2003 client computer users may be able to postpone software update installations beyond the configured time.

Additionally, an error message that is similar to the following is logged in the PatchUIMonitor.log file:
Successfully got advertisement with ID= <AdvertisementID> and UserSID = (null)]hr, HRESULT=80040215 (e:\nts\sms\client\clienthelperapi\advertsched\advertisementschedule.cpp,605)m_sptrAdvertisementSchedule-GetNextScheduledTime(strScheduleID, strUserSid, &strScheduledTime), HRESULT=80040215 Failed to get next schedule -- hRes = 0x80040215Unable to get next recurrence schedule. Mandatory recurrent advertisement is required

CAUSE

This problem occurs because the SMS 2003 client computer cannot correctly determine how long users can postpone the software update installation.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

SMS 2003 Service Pack 1 (SP1)

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Jun-2004  02:50  2.0.156.0         254,455  Deployac.exe     
   24-Oct-2004  21:20                    420,352  Sms2003ac-sp1-kb896611-x86.msp
   24-Oct-2004  21:20  2.50.3174.1141    219,648  Smscliui.exe     
   24-Dec-2003  22:30  2.50.2726.154      40,960  Smsse.dll        
   28-Apr-2005  08:44                        562  Smsconfig.inf

Installation instructions

To install this hotfix, follow these steps:
  1. Create a shared folder in a location that can be accessed by the SMS site servers.
  2. Copy the SMS2003-SP1-KB896611-X86-ENU.exe hotfix file to the new shared folder.
  3. On each SMS primary and secondary site server in the environment that will be distributing the package to clients, log on by using an account that has administrative credentials.
  4. Close the SMS Administrator console if it is open.
  5. Connect to the shared folder that contains the hotfix.
  6. Double-click the SMS2003-SP1-KB896611-X86-ENU.exe hotfix file, and then follow the instructions in the wizard.

WORKAROUND

To work around this problem, make sure that users of SMS 2003 client computers do not postpone software update installations.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kberrmsg kbfix kbExpertiseInter kbSMS2003spfix kbsms200sp2fix KB896611 kbAudITPRO