FIX: You receive an "ArgumentOutOfRangeException" error message when you visit the Commerce Server 2002 Starter Site (896107)



The information in this article applies to:

  • Microsoft Commerce Server 2002

SYMPTOMS

After you unpack, or unpup, the Microsoft Commerce Server 2002 Starter Site application, when you visit the Commerce Server 2002 Starter Site by using a Web browser such as Microsoft Internet Explorer, you receive the following error message:
[ArgumentOutOfRangeException: Specified argument was out of the range of valid values. Parameter name: value]
System.Web.UI.WebControls.ListControl.set_SelectedIndex(Int32 value) +151
System.Web.UI.WebControls.DropDownList.set_SelectedIndex(Int32 value) +5
Microsoft.Solutions.Applications.LanguageDropDown.FillDropDownList() +91
Microsoft.Solutions.Applications.LanguageDropDown.OnInit(EventArgs e) +277

CAUSE

This problem occurs if the Web browser is set to use a language option that is not available in the Commerce Server Starter Site catalog list. This problem occurs because the FindSelectedIndex function in the Languagedropdown.ascx.cs file does not correctly handle all possible detected languages.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the Commerce Server Starter Site after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size    File name
   ----------------------------------------------------
   23-Mar-2005  15:37  14,150  Languagedropdown.ascx.cs

Hotfix installation information

To apply this hotfix, replace the Languagedropdown.ascx.cs file in your Commerce Server Starter Site with the Languagedropdown.ascx.cs file that is included with this hotfix. By default, the Languagedropdown.ascx.cs file is located in the following folder:

StarterSiteRoot\UserControls

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbBug kbfix KB896107 kbAudDeveloper