FIX: The COM+ process stops responding after a Visual Basic application uses the Microsoft Oracle ODBC driver to connect to an Oracle database server that is hosted on a Windows Server 2003-based computer or on a Windows XP-based computer (896100)



The information in this article applies to:

  • Microsoft Data Access Components 2.8
  • Microsoft Data Access Components 2.8 Service Pack 1 (SP1)
  • Microsoft Data Access Components 2.8 Service Pack 2 English (United States)

Bug #: 275911 (SQLBUDT)
Bug #: 281917 (SQLBUDT)
Bug #: 369038 (SQLBUDT)
Bug #: 369039 (SQLBUDT)



SYMPTOMS

Consider the following scenario. A Microsoft Visual Basic application uses the Microsoft Oracle ODBC driver (Msorcl32.dll) to connect to an Oracle database server. The Oracle database server is hosted on a Microsoft Windows Server 2003-based computer or on a Microsoft Windows XP-based computer. In this scenario, the Microsoft COM+ process stops responding (hangs). After this problem occurs, you may have to restart the Visual Basic application to resume the full range of expected functions.

CAUSE

This problem occurs because the Microsoft Oracle ODBC driver loads COM+ components in the DLLMain function. This behavior can cause a deadlock condition.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack or Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Hotfix file information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain of all the files that you must have to fully update a product to the latest build.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dbnetlib.dll2000.85.1060.073,72825-Mar-200517:16x86
Dbnmpntw.dll2000.85.1060.028,67225-Mar-200517:17x86
Msadce.dll2.80.1060.0315,39225-Mar-200517:16x86
Msadco.dll2.80.1060.0135,16825-Mar-200517:16x86
Msadcs.dll2.80.1060.049,15225-Mar-200517:16x86
Msadds.dll2.80.1060.0147,45625-Mar-200517:16x86
Msado15.dll2.80.1060.0507,90425-Mar-200517:16x86
Msadomd.dll2.80.1060.0163,84025-Mar-200517:17x86
Msadox.dll2.80.1060.0184,32025-Mar-200517:17x86
Msadrh15.dll2.80.1060.053,24825-Mar-200517:16x86
Msdaora.dll2.80.1060.0225,28025-Mar-200517:17x86
Msdaprst.dll2.80.1060.0192,51225-Mar-200517:16x86
Msdart.dll2.80.1060.0147,45625-Mar-200517:16x86
Msdasql.dll2.80.1060.0303,10425-Mar-200517:16x86
Msorcl32.dll2.575.1060.0139,26425-Mar-200517:17x86
Odbc32.dll3.525.1060.0221,18425-Mar-200517:16x86
Odbcbcp.dll2000.85.1060.024,57625-Mar-200517:17x86
Oledb32.dll2.80.1060.0442,36825-Mar-200517:16x86
Sqloledb.dll2000.85.1060.0503,80825-Mar-200517:16x86
Sqlsrv32.dll2000.85.1060.0401,40825-Mar-200517:16x86
Sqlxmlx.dll2000.85.1060.0208,89625-Mar-200504:16x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/22/2006
Keywords:kbBug kbfix kbtshoot kbQFE kbpubtypekc KB896100 kbAudITPRO kbAudDeveloper