FIX: It may take an exponentially long time to index long files in a custom application that was built by using the Windows Media Format 9.5 SDK (896097)



The information in this article applies to:

  • Microsoft Windows Media Format 9.5 SDK

SYMPTOMS

Consider the following scenario. You have a custom application that was built by using the Microsoft Windows Media Format 9.5 SDK. When the application indexes long files, you may notice that it may take an exponentially long time to complete the indexing process.

Note Typically, this issue occurs when the files that are being indexed are 90 minutes or longer.

CAUSE

This issue occurs because the data structure that is used for maintaining the list of indexes is inefficient for adding new index points.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia10-KB896097-x86-ENU.exe package now.

For more information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   ---------------------------------------------------
   16-Mar-2005  16:03  10.0.0.3909  226,816  Wmasf.dll

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:11/21/2005
Keywords:kbBug kbfix KB896097 kbAudDeveloper