When you run a program that uses Collaboration Data Objects for Exchange Management (CDOEXM) on a computer that is running Microsoft Exchange 2000 Server, the server may stop responding to client requests (896064)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

When you run a program that uses Collaboration Data Objects for Exchange Management (CDOEXM) on a Microsoft Exchange 2000 Server computer, the server may eventually stop responding to client requests.

When you use System Monitor to view the Private Bytes counter for the process that is associated with the program that uses CDOEXM, you may notice that the memory usage for the process continues to increase.

CAUSE

This problem occurs because of a memory leak in the Cdoexm.dll file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange 2000 Server Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix has the following prerequisites:
  • You must be running Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information about how to obtain the latest Exchange 2000 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

    301378 How to obtain the latest Exchange 2000 Server service pack

  • You must have the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    870540 Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, Microsoft Exchange services and Microsoft Internet Information Services (IIS) services are automatically stopped and then restarted during the hotfix installation.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Apr-2005  04:47  6.0.6617.63     2,109,440  Cdoexm.dll          
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbExchange2000preSP4fix kbbug KB896064 kbAudITPRO