The primary IP address is reset to 0.0.0.0 after you disconnect and reconnect the network cable in Windows XP (896062)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)

SYMPTOMS

You configure two or more static Internet Protocol (IP) addresses on a computer that is running Microsoft Windows XP. Then, you disconnect and reconnect the network cable. In this scenario, the primary IP address is reset to 0.0.0.0. The primary IP address is not restored after the network cable is reconnected.

CAUSE

This problem occurs because of a race condition that involves the TCP/IP driver and the DHCP client service.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Windows XP Service Pack 1 installed.

Restart requirement

You must restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows XP with Service Pack 1, 32-bit versions
File nameFile versionFile sizeDateTime
Dhcpcsvc.dll5.1.2600.1687102,91216-May-200516:15
Windows XP with Service Pack 2, 32-bit versions
File nameFile versionFile sizeDateTime
Dhcpcsvc.dll5.1.2600.2677111,10416-May-200516:20
Windows XP, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Dhcpcsvc.dll5.1.2600.1687322,04816-May-200517:13IA-64Not applicable
Wdhcpcsvc.dll5.1.2600.1687102,91216-May-200517:15x86WOW

WORKAROUND

To work around this problem, disable Media Sensing for TCP/IP. For more information about how to disable Media Sensing, click the following article number to view the article in the Microsoft Knowledge Base:

239924 How to disable Media Sensing for TCP/IP in Windows

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbWinXPpreSP3fix kbprb KB896062 kbAudITPRO kbAudDeveloper