Your Windows XP-based computer stops responding if you install or upgrade to Windows XP Service Pack 2 (893356)



The information in this article applies to:

  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Home Edition SP2

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you install or upgrade to Microsoft Windows XP Service Pack 2 (SP2), your computer may stop responding (hang). This symptom occurs when you see the Windows XP logo screen with the following message: Please wait. This symptom occurs after the Graphical User Interface (GUI) mode installation finishes and the computer is restarted.

CAUSE

This issue occurs if your computer is using one of the following VIA processors:
Product nameProcessor coreProcessor CPUID
C3 800MHz and Eden ESP 3000/4000/5000/6000 Samuel2 Family=6 Model=7
C3 1.0GHzEzra-TFamily=6 Model=8
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

WORKAROUND

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this issue, use the appropriate method.

Workaround for situations where the issue has already occurred

To work around this issue after the issue has occurred, follow these steps:
  1. Restart your computer so that Windows XP SP2 Setup can continue.
  2. Run Chkdsk to fix any errors on the disk. To do this, follow these steps:
    1. Click Start, click Run, type cmd in the Open box, and then click OK.
    2. At the command prompt, type chkdsk /f , and then press ENTER.

Workarounds to prevent this issue

If you have not yet installed Windows XP SP2 on the computer that uses one of the affected VIA processors, use either of the following workarounds to prevent this issue when you install Windows XP SP2.

Workaround one

Upgrade Windows Media Player to version 10 before you upgrade the computer to Windows XP SP2. The issue that is described in this article does not occur when you have Windows Media Player 10 installed. To download Windows Media Player 10, visit the following Microsoft Web site:

Workaround two

Upgrade the computer to Windows XP SP2. However, do not restart the computer when you are prompted. Instead, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following subkey in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{6BF52A52-394A-11d3-B153-00C04F79FAA6}\InprocServer32

  3. In the right pane, double-click the (Default) entry.
  4. In the Value data box, change the value from the old value to the new value, and then click OK:

    Old value: C:\WINDOWS\system32\wmp.dll
    New value: C:\WINDOWS\system32\wmp1.dll

  5. Quit Registry Editor, and then restart the computer.
Restore the registry entry to its original value after you complete the installation of Windows XP SP2. To do this, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following subkey in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{6BF52A52-394A-11d3-B153-00C04F79FAA6}\InprocServer32

  3. In the right pane, double-click the (Default) entry.
  4. In the Value data box, change the value from the old value to the new value, and then click OK:

    Old value: C:\WINDOWS\system32\wmp1.dll
    New value: C:\WINDOWS\system32\wmp.dll

  5. Quit Registry Editor, and then restart the computer.

Workaround for an unattended installation

Note Before you perform an unattended installation by using the following steps, make sure that your computer is using a VIA processor. If the unattended installation is not completed successfully, contact the computer manufacturer for help.

To work around this issue if you want to apply an unattended installation to a computer that has a VIA Processor, follow these steps:
  1. Create the following folder structure for your $OEM$ folder:

    C:\$OEM$\$1\Sysprep\I386\$OEM$

  2. Use a text editor, such as Notepad, to create a file that contains the following text:

    REGEDIT4
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{6BF52A52-394A-11d3-B153-00C04F79FAA6}\InprocServer32]
    @="C:\\WINDOWS\\system32\\wmp1.dll"

  3. Save the file as Rename.reg in the C:\$OEM$\$1\Sysprep folder.
  4. Use any text editor, such as Notepad, to add the following text to the [Unattended] section of the Unattend.txt file in the Sysprep folder:

    [GuiRunOnce]
    Command0 = "c:\Windows\regedit /s C:\Sysprep\Rename.reg"

  5. Create a file that contains the following text:

    [Commands]
    "C:\Windows\regedit /s c:\sysprep\Original.reg"

  6. Save the file as Cmdlines.txt in the C:\$OEM$\$1\Sysprep\I386\$OEM$ folder.
  7. Create a file that contains the following text:

    REGEDIT4

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{6BF52A52-394A-11d3-B153-00C04F79FAA6}\InprocServer32]
    @="C:\\WINDOWS\\system32\\wmp.dll"

  8. Save the file as Original.reg in the C:\$OEM$\$1\Sysprep folder.
  9. Create a file that contains the following text:

    [Unattended]
    InstallFilesPath = "C:\Sysprep\i386"
    [GuiRunOnce]

    Note You must include a blank [GUIRunOnce] section in your Sysprep.inf file.
  10. Save the file as Sysprep.inf in the C:\$OEM$\$1\Sysprep folder.
Note The Cmdlines.txt file is processed to reset the registry key when the user clicks Finish on the last Windows Welcome Screen.

Modification Type:MajorLast Reviewed:4/25/2006
Keywords:kbtshoot KB893356 kbAudEndUser