FIX: The Mqmig.exe program may stop responding when you migrate from Message Queue Server 1.0 in Windows NT 4.0 to Message Queuing 3.0 in Microsoft Windows Server 2003 (893054)



The information in this article applies to:

  • Microsoft Message Queuing 3.0
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows NT 4.0

SYMPTOMS

When you migrate from Microsoft Message Queue Server, also known as MSMQ, 1.0 in Microsoft Windows NT 4.0 to Microsoft Message Queuing 3.0 in Microsoft Windows Server 2003, the Mqmig.exe program may stop responding.

CAUSE

This problem may occur when one of the following conditions is true:
  • You use the Mqmig.exe program to perform the migration.
  • You try to migrate when the backup site controller is offline.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

You must apply this hotfix before you try to migrate from Message Queue Server 1.0 in Windows NT 4.0 to Message Queuing 3.0 in Windows Server 2003. When you apply this hotfix, you can perform the migration process in phases. However, if you run the migration tool without applying this hotfix, all servers that are running Windows NT 4.0 Message Queuing Information Services (MQIS) stop running, and you must complete the migration immediately.

The hotfix in this article lets you perform migration in the following planned phases:
  1. Migrate all objects from the Windows NT 4.0 MQIS database to Active Directory. Skip the phases in the migration tool that update a client computer registry and that demote servers that are running Windows NT 4.0 MQIS.
  2. Manually complete the migration of several client computers, and test them in the Active Directory environment.
  3. When testing is complete, run the migration tool again. Update all clients and servers that are running Windows NT 4.0 MQIS. Until then, the Windows NT 4.0 Message Queue Server environment continues to run as it did before the migration. The environment is not affected by the migration of objects that was performed in the first phase.
For additional information about migrating controller servers that are running Message Queue Server 1.0 into a Windows Server 2003 domain, visit the following Microsoft Web site:

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit versions
Date         Time    Version          Size      File name     
-----------------------------------------------------------------
08-Feb-2005  01:16   5.2.1732.266     77,312    Mqac.sys
08-Feb-2005  21:00   5.2.1732.266     146,432   Mqad.dll 
08-Feb-2005  21:00   5.2.1732.266     192,000   Mqads.dll 
08-Feb-2005  01:16   5.2.1732.266     28,160    Mqbkup.exe 
08-Feb-2005  21:00   5.2.1732.266     9,728     Mqcertui.dll 
08-Feb-2005  21:00   5.2.1732.266     31,232    Mqdbodbc.dll 
08-Feb-2005  21:00   5.2.1732.266     47,616    Mqdscli.dll 
08-Feb-2005  21:00   5.2.1732.266     48,128    Mqdssrv.dll 
08-Feb-2005  21:00   5.2.1732.266     44,544    Mqgentr.dll 
08-Feb-2005  21:00   5.2.1732.266     28,160    Mqise.dll 
08-Feb-2005  21:00   2001.12.4720.26  71,680    Mqlogmgr.dll 
08-Feb-2005  01:16   5.2.1732.266     39,424    Mqmig.exe 
08-Feb-2005  18:00   5.2.1732.266     216,576   Mqmigrat.dll 
08-Feb-2005  21:00   5.2.1732.266     230,400   Mqoa.dll 
08-Feb-2005  21:00   5.2.1732.266     15,872    Mqperf.dll 
08-Feb-2005  21:00   5.2.1732.266     778,752   Mqqm.dll 
08-Feb-2005  21:00   5.2.1732.266     169,472   Mqrt.dll 
08-Feb-2005  21:00   5.2.1732.266     117,248   Mqrtdep.dll 
08-Feb-2005  21:00   5.2.1732.266     133,632   Mqsec.dll 
08-Feb-2005  21:00   5.2.1732.266     508,928   Mqsnap.dll 
08-Feb-2005  21:00   5.2.1732.266     50,176    Mqupgrd.dll 
08-Feb-2005  21:00   5.2.1732.266     421,888   Mqutil.dll 
08-Feb-2005  00:37                    271       Branches.inf
08-Feb-2005  21:06                    17,179    Kb893054.cat
08-Feb-2005  21:01                    375       Updatebr.inf
08-Feb-2005  21:01                    7,975     Update_rtmqfe.inf
Windows Server 2003, 64-bit version
Date         Time   Version            Size    File name	       Platform
-------------------------------------------------------------------------
08-Feb-2005  01:20  5.2.1732.266      270,848  Mqac.sys
08-Feb-2005  21:00  5.2.1732.266      488,448  Mqad.dll         IA-64
08-Feb-2005  21:00  5.2.1732.266      618,496  Mqads.dll        IA-64
08-Feb-2005  01:21  5.2.1732.266       74,752  Mqbkup.exe       IA-64
08-Feb-2005  21:00  5.2.1732.266       23,040  Mqcertui.dll     IA-64
08-Feb-2005  21:00  5.2.1732.266      127,488  Mqdscli.dll      IA-64
08-Feb-2005  21:00  5.2.1732.266      120,320  Mqdssrv.dll      IA-64
08-Feb-2005  21:00  5.2.1732.266      138,752  Mqgentr.dll      
08-Feb-2005  21:00  5.2.1732.266       79,872  Mqise.dll        IA-64
08-Feb-2005  21:00  2001.12.4720.26   218,624  Mqlogmgr.dll     IA-64
08-Feb-2005  21:00  5.2.1732.266      628,736  Mqoa.dll         IA-64
08-Feb-2005  21:00  5.2.1732.266       37,888  Mqperf.dll       IA-64
08-Feb-2005  21:00  5.2.1732.266    2,732,544  Mqqm.dll         IA-64
08-Feb-2005  21:00  5.2.1732.266      524,288  Mqrt.dll         IA-64
08-Feb-2005  21:00  5.2.1732.266      358,400  Mqrtdep.dll      IA-64
08-Feb-2005  21:00  5.2.1732.266      434,688  Mqsec.dll        IA-64
08-Feb-2005  21:00  5.2.1732.266    1,636,864  Mqsnap.dll       IA-64
08-Feb-2005  21:00  5.2.1732.266      163,328  Mqupgrd.dll      IA-64
08-Feb-2005  21:00  5.2.1732.266      424,960  Mqutil.dll       IA-64
08-Feb-2005  21:00  5.2.1732.266      146,432  Wmqad.dll        x86
08-Feb-2005  21:00  5.2.1732.266       47,616  Wmqdscli.dll     x86
08-Feb-2005  21:00  5.2.1732.266      230,400  Wmqoa.dll        x86
08-Feb-2005  21:00  5.2.1732.266       15,872  Wmqperf.dll      x86
08-Feb-2005  21:00  5.2.1732.266      169,472  Wmqrt.dll        x86
08-Feb-2005  21:00  5.2.1732.266      133,632  Wmqsec.dll       x86
08-Feb-2005  21:00  5.2.1732.266      421,888  Wmqutil.dll      x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbfix kbbug kbHotfixServer kbQFE KB893054 kbAudDeveloper