The Microsoft Operations Manager 2005 agent does not respond or send alerts when you install it on a MOM Management Server (892683)



The information in this article applies to:

  • Microsoft Operations Manager 2005

SYMPTOMS

When you install the Microsoft Operations Manager (MOM) 2005 agent on a computer that is acting as the MOM Management Server, the MOM agent may not communicate with or send alerts to the Management Server.

Additionally, the MOMService.mc8 log file may contain the following error message:
Active configuration is not available
Note This log file is located in the %windir%\Temp\Microsoft Operations Manager folder on the Management Server.

Additionally, the ConfigCache file on the Management Server may be only 12 kilobytes (KB). By default, the ConfigCache file is located in the Documents and Settings\All Users\Application Data\Microsoft\Microsoft Operations Manager\ManagementGroupName folder on the Management Server.

CAUSE

This problem typically occurs when the following registry subkey is missing on the Management Server:

HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\ONEPOINT\Configurations\ConfigurationName\Operations\agent

RESOLUTION

To resolve this problem, export the missing MOM agent registry subkey from a computer that has a working version of the MOM agent installed. Then, import the missing registry subkey to the Management Server. To do this, follow these steps:
  1. Log on to a computer that has a working version of the MOM agent installed. Use an account that has administrative permissions.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\ONEPOINT\Configurations\ConfigurationName\Operations\agent

    Note ConfigurationName is the name of the MOM 2005 management group.
  4. On the File menu, click Export.
  5. In the Export Registry File dialog box, specify a location that can be accessed by the Management Server by using an account that has administrative permissions.
  6. Log on to the MOM Management Server, and then locate the shared network drive or folder that contains the exported registry file (.reg).
  7. Right-click the exported registry file, and then click Merge.
  8. When a dialog box appears that prompts you to confirm that you want to add the information to the registry, click Yes, and then click OK.

    Note After you complete these steps, the 21290 event is generated. To avoid such behavior, you must configure the Agent Proxy to prevent the MOM agent from acting as a proxy for other computers. To do this, follow these steps:
    1. Click Start, point to Programs, point to Microsoft Operations Manager 2005, and then click Administrator Console.
    2. In the MOM Administrator console, expand Microsoft Operations Manager (ServerName), expand Administration, click Global Settings, right-click Agents, and then click Properties.
    3. In Agent Properties, click the Security tab. Make sure that the Agent Proxying check box is enabled, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbtshoot kbprb KB892683 kbAudITPRO