The error message "An error occurred during the mapping of computer accounts" is logged in the Import.log file when you run the Microsoft CRM 1.2 Redeployment Tool (889685)



The information in this article applies to:

  • Microsoft CRM 1.2

SYMPTOMS

An error message that is similar to the following is logged in the Import.log file when you run the Microsoft Business Solutions CRM 1.2 Redeployment Tool. This log file is located in the root directory of the system disk.
Search root is : LDAP://SBS 10/20/2004 16:42:28 Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: startIndex 10/20/2004 16:42:28 mscorlib 10/20/2004 16:42:28
An error occurred during the mapping of computer accounts. The mapping failed. 10/20/2004 16:42:34 Import ended

CAUSE

The Microsoft CRM 1.2 Redeployment Tool filters for any objects in the Active Directory directory service. The Redeployment Tool does not filter for computer objects only. The error message is logged if the domain where you are running the Redeployment Tool has the same name as the computer object.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version of Microsoft Business Solutions CRM that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Apply this hotfix to computers that are running the Microsoft CRM 1.2 Redeployment Tool.

Prerequisites

To apply this hotfix, you must have the Microsoft CRM 1.2 Redeployment Tool installed.

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted, restart the computer after you apply the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version       Size     File name
-----------------------------------------------------------
18-Jan-2005  01:10  1.2.4121.101  195,296  Sdtransform.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft CRM 1.2 Redeployment Tool.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbMBSredeploymenttool kbprb kberrmsg kbMBSMigrate kbQFE kbHotfixServer KB889685