You receive an "Access is denied" error message when you open a Web page that runs a script in a frameset in Internet Explorer 6 (889407)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

You open a Web page that contains a frameset in Microsoft Internet Explorer 6. If a script runs in the left frame of the frameset, you receive the following error message:
Problems with this Web page might prevent it from being displayed properly or functioning properly. In the future, you can display this message by double-clicking the warning icon displayed in the status bar.

Line: 6
Char: 2
Error: Access is denied.
Code: 0
URL: http://URLpath/frameset.html

CAUSE

This problem occurs when the following conditions are true:
  • The domain property is explicitly defined in a cross-frame script. For example, the domain property is Microsoft.com.
  • One of the following is true:
    • You have Microsoft Windows XP Service Pack 2 (SP2) installed.
    • You have Internet Explorer 6 Service Pack 1 (SP1) installed, and you install the cumulative security update for Internet Explorer (MS04-025).

      For additional information about the cumulative security update for Internet Explorer, click the following article number to view the article in the Microsoft Knowledge Base:

      867801 MS04-025: Cumulative security update for Internet Explorer

RESOLUTION

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer 6 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP SP2 installed to apply this hotfix.

Restart information

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any later hotfixes.

Registry information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To enable this hotfix, follow these steps:
  1. Exit Internet Explorer 6.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl

  4. On the Edit menu, point to New, and then click Key.
  5. Type FEATURE_DOC_WRITE_DOMAIN_KB886184, and then press ENTER.
  6. With the FEATURE_DOC_WRITE_DOMAIN_KB886184 subkey selected, on the Edit menu, point to New, and then click DWORD Value.
  7. Type Iexplore.exe, and then press ENTER.
  8. Right-click Iexplore.exe, and then click Modify.
  9. In the Value data box, type 1, and then click OK.
  10. On the File menu, click Exit to exit Registry Editor.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   10-Feb-2005  17:19  6.00.2900.2608  3,008,000  Mshtml.dll 
				

STATUS

Microsoft has confirmed that this is a problem in the version of Internet Explorer 6 that is included in Microsoft Windows XP SP2.

MORE INFORMATION

For more information about the domain property, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbfix kbWinXPpreSP3fix kbQFE kbBug kbHotfixServer KB889407 kbAudEndUser kbAudITPRO