Non-administrative users can remotely shut down a Windows XP Service Pack 1-based computer by using the TSShutdn.exe command (889323)



The information in this article applies to:

  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

A non-administrative user can remotely shut down a Microsoft Windows XP Service Pack 1 (SP1)-based computer by using the TSShutdn.exe command.

CAUSE

This problem occurs because the Remote Desktop does not check the Force shutdown from a remote system user right.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows XP SP1

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows XP 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   16-Mar-2005  17:36  5.1.2600.1646      32,768  Cfgbkend.dll     
   16-Mar-2005  17:36  5.1.2600.1646      30,720  Pchsvc.dll       
   16-Mar-2005  17:36  5.1.2600.1646      39,424  Racpldlg.dll     
   16-Mar-2005  17:36  5.1.2600.1646      44,544  Regapi.dll       
   16-Mar-2005  17:36  5.1.2600.1646      41,472  Safrslv.dll      
   16-Mar-2005  01:44  5.1.2600.1646     130,560  Sessmgr.exe      
   16-Mar-2005  17:36  5.1.2600.1646     200,192  Termsrv.dll      
   16-Mar-2005  17:36  5.1.2600.1646      88,064  Tscfgwmi.dll     
   16-Mar-2005  01:46  5.1.2600.1646     594,432  Xpsp2res.dll     
   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll     
Windows XP 64-bit versions
   Date         Time   Version            Size    File name	 Platform																													     Platform
   ----------------------------------------------------------------------
   16-Mar-2005  16:33  5.1.2600.1646     104,448  Cfgbkend.dll   IA-64
   16-Mar-2005  16:33  5.1.2600.1646     110,592  Pchsvc.dll     IA-64
   16-Mar-2005  16:33  5.1.2600.1646     106,496  Racpldlg.dll   IA-64
   16-Mar-2005  16:33  5.1.2600.1646     127,488  Regapi.dll     IA-64
   16-Mar-2005  16:33  5.1.2600.1646     111,616  Safrslv.dll    IA-64
   16-Mar-2005  00:58  5.1.2600.1646     423,424  Sessmgr.exe    IA-64
   16-Mar-2005  16:33  5.1.2600.1646     622,592  Termsrv.dll    IA-64
   16-Mar-2005  16:33  5.1.2600.1646     326,144  Tscfgwmi.dll   IA-64
   16-Mar-2005  01:06  5.1.2600.1646     593,920  Xpsp2res.dll   IA-64
   16-Mar-2005  16:36  5.1.2600.1646      44,544  Wregapi.dll    X86
   16-Mar-2005  00:46  5.1.2600.1646     594,432  Wxpsp2res.dll  X86
   25-Feb-2005  02:50  6.1.22.4          639,712  Updspapi.dll   IA-64

Important This problem has been resolved in Microsoft Windows XP Service Pack 2 (SP2).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB889323 kbAudITPRO