Input.dll error message when you click Details in the Regional and Language Options dialog box (887852)



The information in this article applies to:

  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Home Edition SP2

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

You click the Languages tab in the Regional and Language Options dialog box on a computer that is running the Japanese version or the Korean version of Microsoft Windows XP. When you click Details, you receive the following error message:
:shell32.dll control.run.dll input.dll

CAUSE

Input Method Editor (IME) 9 is not set as the default input method editor.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, use one of the following methods depending on your version of Windows XP:

Japanese

  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key: HKCU\Software\Microsoft\IMEJP\9.0\SetPreload
  3. In the right pane, right-click the SetPreload DWORD value, and then click Delete.
  4. Quit Registry Editor.
  5. Restart the computer.
Note If there are other user accounts on the computer, log on to the computer as each user, and then follow these steps for each user.

Korean

  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key: HKEY_Current_User\Software\Microsoft\IMEKR\7.0\Migrated
  3. Right-click Migrated, and then click Delete.
  4. Quit Registry Editor.
  5. Restart the computer.
Note If there are other user accounts on the computer, log on to the computer as that user, and then follow these steps for each user.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:1/26/2005
Keywords:kbprb KB887852 kbAudOEM kbAudEndUser