The Exchange Server Migration Wizard may not correctly migrate e-mail message information when you migrate IBM Lotus Notes mailboxes to Microsoft Exchange Server 2003 (887577)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition, Service Pack 1 (SP1)
  • Microsoft Exchange Server 2003 Enterprise Edition, Service Pack 1 (SP-1)

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use the Exchange Server Migration Wizard (Mailmig.exe) to migrate IBM Lotus Notes mailboxes to Microsoft Exchange Server 2003 Service Pack 1, the Exchange Server Migration Wizard may not correctly migrate the e-mail message information. For example, Exchange 2003 may incorrectly label some of the e-mail messages that you migrate as messages that were sent by a delegate. When you view the .pri file, the Sent-Representing field is unexpectedly populated.

CAUSE

This problem may occur when the following conditions are true:
  • You migrate IBM Lotus Notes mailboxes by using the Exchange Server Migration Wizard.
  • The IBM Lotus Notes mailboxes contain e-mail messages that have two or more IBM Lotus Notes domains in the e-mail address, such as UserA/NotesSrv1@NotesDomain1@NotesDomain2.
This problem occurs because the Exchange Server Migration Wizard does not remove the IBM Lotus Notes routing information.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Exchange Server 2003 Service Pack 1.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Jan-2005  23:02  6.5.7232.72        59,904  Mlmignts.dll 

After you install the hotfix

After you install this hotfix, you must create a Windows registry subkey and entry. To do this, follow these steps. Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange

  3. Right-click Exchange, point to New, click Key, type MSExchangeMailMig, and then press ENTER.
  4. Right-click MSExchangeMailMig, point to New, click Multi-String Value, type RoutableDomains, and then press ENTER.
  5. Right-click RoutableDomains, and then click Modify. In the Value data box, type the domain names of the domains that are in the IBM Lotus Notes e-mail address.

    For example, an IBM Lotus Notes e-mail address of UserA/NotesSrv1@NotesDomain1@NotesDomain2, would have the following data:

    NotesDomain1
    NotesDomain2

    Note Separate the domain names by pressing ENTER.
  6. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbBug kbExchange2003preSP1fix KB887577 kbAudITPRO