The CCM component in Systems Management Server 2003 tries to install the Advanced Client on 64-bit versions of Windows even though the Advanced Client is already installed (886902)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

The Client Configuration Manager (CCM) component in Microsoft Systems Management Server (SMS) 2003 tries to install the Advanced Client software on client computers that are running the 64-bit version of Microsoft Windows Server 2003 or of Microsoft Windows XP. The CCM component does this even though the Advanced Client software is already installed on these client computers. In this scenario, the following is logged in the SMS\Logs\ccm.log file, where computer is the name of the client computer:

Unable to retrieve the mobile client version from machine "computer".
Client type to be installed on computer: Advanced client

This problem does not occur when the Advanced Client is installed on a 32-bit version of Windows.

CAUSE

This problem occurs because the CCM component does not recognize the Advanced Client software that is already installed on the client computers in this scenario. Advanced Client registry keys are stored in the Windows-32-on-Windows-64 (WOW64) subsystem registry keys on computers that are running the 64-bit version of Windows Server 2003 or of Windows XP. When a remote 32-bit program, such as the CCM component, tries to access the client's registry, the registry read requests are not redirected to the WOW64 subsystem keys of the client's registry. Therefore, the CCM component incorrectly tries to read the 64-bit registry keys instead of the WOW64 subsystem registry keys.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have SMS 2003 Service Pack 1 (SP1) installed to install this hotfix.

Restart requirement

This hotfix will stop and then restart the following services:
  • SMS_SITE_COMPONENT_MANAGER
  • SMS_EXECUTIVE
  • SMS_SQL_MONITOR

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------
   25-Oct-2004  09:10  2.50.3174.1139    237,568  Ccm.dll 

The SMS 2003 International Client Pack (ICP) 1 version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------
   25-Oct-2004  09:10  2.50.3174.1139    237,568  Ccm.dll 

The SMS 2003 International Client Pack (ICP) 2 version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------
   25-Oct-2004  09:10  2.50.3174.1139    237,568  Ccm.dll 

Hofix installation information

To install this hotfix, follow these steps on each SMS 2003 site server in your hierarchy:
  1. Copy the SMS2003-SP1-KB886902-X86-ENU.exe file to a local folder on the site server or to a shared network folder.
  2. Double-click SMS2003-SP1-KB886902-X86-ENU.exe to start the hotfix installation wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about standard terminology that is used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMSInstall kbSMSClients kbSMS2003spfix kbSMS2003bug kbClient kberrmsg kbsetup kbinterop kbfix KB886902 kbAudITPRO