A disk signature is unexpectedly changed on a Windows Server 2003 clustered physical disk resource (886800)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

The disk signature and the globally unique identifier (GUID) for a disk may change unexpectedly on Microsoft Windows Server 2003 computers that have redundant Host Bus Adapters (HBA) configured for a common external disk. When this problem occurs, programs that depend on this disk signature in the master boot record (MBR) may fail.

Windows Server 2003 clustering uses the disk signature and the disk GUID to mount a disk and to bring that disk online. If the disk signature changes, the disk may fail, and the following error message may be logged in the system event log:Event ID: 1034
Source: ClusDisk
Description: The disk associated with cluster disk resource DriveLetter could not be found. The expected signature of the disk was DiskSignature.Additionally, if the disk signature or the disk GUID changes unexpectedly, drive letters may be reassigned or reordered after the computer is restarted.

You may also experience this problem after you remove the HP Secure Path program from a cluster node that is running Microsoft Windows Server 2003. When you restart the cluster node, you receive the following Stop error message in the FTDisk.sys driver:
Stop 0x000000CA (PNP_DETECTED_FATAL_ERROR)

CAUSE

This problem may occur if two nodes in a cluster run detection logic at the same time, and if one of the cluster nodes changes the disk signature. When the hotfix that is listed in the Resolution section is installed, disk signatures and disk GUIDs will not be changed in the future if the two nodes in a cluster run detection logic at the same time.

RESOLUTION

For more information about how to recover from an Event ID 1034 error, click the following article number to view the article in the Microsoft Knowledge Base:

280425 Recovering from an event ID 1034 on a server cluster

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 64-bit editions
   Date         Time   Version         Size  File name    Platform
   ---------------------------------------------------------------
   04-Oct-2004  18:42  5.2.3790.220  69,632  Partmgr.sys  IA-64
Windows Server 2003 32-bit editions
   Date         Time   Version         Size  File name    Platform
   ---------------------------------------------------------------
   04-Oct-2004  19:51  5.2.3790.220  36,352  Partmgr.sys  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbQFE kbHotfixServer kbClustering kbBug kbfix kbWinServ2003preSP1fix KB886800 kbAudITPRO