You cannot use the Distribute Software Updates Wizard to authorize updates that are reported by the SMS 2003 Inventory Tool for Dell Update (886759)



The information in this article applies to:

  • Microsoft Systems Management Server 2003 SP1

SYMPTOMS

When you use the Distribute Software Updates Wizard in Microsoft Systems Management Server (SMS) 2003 with Service Pack 1 (SP1), you cannot authorize updates that are detected by the SMS 2003 Inventory Tool for Dell Update. The available updates do not appear in the wizard.

Note The SMS 2003 Inventory Tool for Dell Update helps you determine the software compliance of your Dell servers. The SMS 2003 Inventory Tool for Dell Update lets you deploy Dell BIOS, Dell firmware, and Dell driver updates to your Dell servers.

CAUSE

This problem occurs because SMS 2003 SP1 does not recognize updates from Dell. To use the Distribute Software Updates Wizard to install updates from Dell, you must apply the hotfix that is described in the "Resolution" section. Specifically, you must apply this hotfix to your SMS 2003 SP1 primary site server and to all SMS 2003 SP1 remote SMS Administrator Console computers in your environment that are used to authorize updates from Dell.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is now available from Microsoft. This hotfix is included in the SMS 2003 Inventory Tool for Dell Update. For more information about the SMS 2003 Inventory Tool for Dell Update, visit the following Microsoft Web site:

Note You do not have to install the SMS 2003 Inventory Tool for Dell Update to obtain this hotfix. However, you must extract the files to obtain this hotfix. After you extract the files, this hotfix is located in the SMSITDU2003_ENU\HOTFIXES\KB886759 folder.

Prerequisites

You must have SMS 2003 SP1 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, if you do not close the SMS Administrator Console before you apply this hotfix, you may be prompted to restart your computer. This behavior occurs if the SMS Administrator Console is using a file that the hotfix installation tries to update.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   16-Jan-2005  22:49  2.50.3174.1120    571,392  Sms2003-sp1-kb886759-x86-enu.exe 
After the fix is installed, the following files will have the listed attributes or later versions:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Oct-2004  11:35  2.50.3174.1120    151,552  Patchdownloader.dll  
   20-Oct-2004  11:35  2.50.3174.1120    196,608  Pwiz_res.dll     
   20-Oct-2004  11:35  2.50.3174.1120    614,400  Sms_pdw.dll 

Hotfix installation information

You must install this hotfix on all SMS 2003 SP1 site servers and on all remote administration consoles that you use to authorize Dell updates. To install this hotfix, follow these steps:
  1. Download and run the SMS2003ITDU_ENU.exe compressed tool file. Specify a folder to extract the files to, click Unzip, and then click Close. By default, the files are stored in the SSM2003ITDU_ENU folder.
  2. In the folder where you extracted the files, open the Hotfixes\KB886759\xxx folder, where xxx is the language of your SMS site server.
  3. Double-click the SMS2003-SP1-KB886759-X86-xxx.exe file to start the Setup wizard.
  4. Click I Agree on the License Agreement page, click Next, and then click Finish.
To perform a silent installation of this hotfix, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, change to the folder that contains the SMS2003-SP1-KB 886658-X86-xxx.exe file. xxx is the language of your SMS site server.
  3. At the command prompt, type SMS2003-SP1-KB 886759-X86-xxx.exe /s, and then press ENTER.

How to remove this hotfix

To remove the hotfix from the SMS site server, follow these steps:
  1. Click Start, point to Control Panel, and then click Add or Remove Programs.
  2. Click Hotfix for Systems Management Server 2003 (KB886759), and then click Remove.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected In Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information about the standard terminology that is used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:3/7/2006
Keywords:kbsmsUtil kbSMSUpdates kbSMSSecurity kbSMSPackage kbSMSInventory kbSMSDistribution kbSMSDeploy kbSMS2003bug kbQFE kbInventory kbinterop kbSoftwareDist kbSecurity kbMiscTools kbfix KB886759 kbAudITPRO