SYMPTOMS
Assume that you are connected to one network in Microsoft Internet Security and Acceleration (ISA) Server 2004, and then you try to access a File Transfer Protocol (FTP) server that is connected to a different network. In this scenario, you may experience one of the following symptoms:
CAUSE
This problem occurs if the following conditions are true:
- The ISA Server 2004 Firewall Client program is installed and enabled.
- The Enable folder view for FTP sites check box is selected in Internet Explorer.
Note If this check box is selected, Internet Explorer exhibits the same behavior as a typical FTP client program. This behavior is described in RFC 959.
If this check box is not selected, Internet Explorer sends FTP requests to the Web proxy server as HTTP requests.
To view RFC 959, visit the following Network Working Group Web site:
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
- The Use Passive FTP check box is not selected in Internet Explorer.
Note This check box controls whether Internet Explorer uses active mode or passive mode FTP.
To locate these check boxes, follow these steps:
- Start Internet Explorer.
- On the Tools menu, click Internet Options.
- Click the Advanced tab, and then under Browsing, locate the following check boxes:
Enable folder view for FTP sites
Use Passive FTP
This problem does not occur if the following conditions are true:
- You use the Ftp.exe command-line FTP client program.
- The Firewall Client program is not installed, and your computer is configured as a SecureNAT client.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Security and Acceleration Server 2004 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
No prerequisites are required to install this hotfix.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
----------------------------------------------------------
20-Sep-2004 4.0.2161.85 73,464 Ftpfltr.dll