Site server does not function after it is moved to a new domain in Systems Management Server 2.0 (883988)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

After you change the name of a domain where you have installed Microsoft Systems Management Server 2.0 (SMS), your SMS site no longer works correctly. You experience the following symptoms:
  • SMS components, such as client access points and logon points, do not install correctly.
  • Entries that are similar to the following are logged to the Smsexec.log file:

    ERROR: Could not write 
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Components\SMS_EXECUTIVE to the registry: 
    No mapping between account names and security IDs was done.
    

CAUSE

This issue may occur if the SMSServer_Sitecode account of the site is not updated to use the new domain name.

RESOLUTION

To resolve this issue, create a new SMSServer_Sitecode account in your new domain, and then configure the SMS site to use the new SMSServer_Sitecode account.

Note Before you follow the steps in this article, make sure that you have obtained and installed the Microsoft Systems Management Server Recovery Tools. To obtain the Microsoft Systems Management Server Recovery Tools, visit the following Microsoft Web site:

Create a new SMSServer_Sitecode account in your new domain

To create a new SMSServer_Sitecode account, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. Right-click Users, point to New, and then click User.
  3. In the First name box, type SMSServer_Sitecode. For example, if your site code is P01, type SMSServer_P01.
  4. In the User logon name box, type SMSServer_Sitecode, and then click Next. For example, if your site code is P01, type SMSServer_P01, and then click Next.
  5. Specify a password for the SMSServer_Sitecode account.

    Note The password that you specify here is reset to a strong password when you run a site reset to configure your SMS site to use your new SMSServer_Sitecode account. The steps to configure your SMS site to use your new SMSServer_Sitecode account are described later in this article. However, you will need the password that you specify here to run the site reset operation. Therefore, make a note of the password that you use for your new SMSServer_SiteCode account.
  6. Click to clear the User must change password and next logon check box, and then click Next.
  7. Specify whether you want to create an Exchange mailbox if you have Microsoft Exchange Server installed, click Next, and then click Finish.

Configure your SMS site to use your new SMSServer_Sitecode account

To configure your SMS site to use your new SMSServer_Sitecode account, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, change to the driveletter:\SMS\Bin\I386 folder.
  3. To configure your site to use your new SMSServer_Sitecode account, type the following command line, and then press ENTER:

    setup.exe /SERVERACCOUNT domain\SMSServer_SiteCode /SERVERPASSWORD password




    Important Make sure that you replace domain with your domain name. Make sure that you replace SiteCode with your three-letter site code, and make sure that you replace password with the password that you assigned to your new SMSServer_Sitecode account in the steps that are described earlier in this article.
  4. Click Next until you reach the Setup Options page.
  5. Click the Modify or reset the current installation option, and then click Next.
  6. Follow the instructions in the Setup wizard.

    Note This step may take some time to complete. Let the site reset complete before you go to the next step.
  7. Install Systems Management Server 2.0 Recovery Tools, if you have not already.
  8. Run the Access Control List (ACL) Reset tool (Aclreset.exe) and use the /RESETALL switch. For a more information about how to run the ACL Reset tool, see the Systems Management Server 2.0 Recovery Tools Help file.
  9. Run another site reset. To do this:
    1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Setup.
    2. Click Next two times.
    3. On the Setup Options page, click Modify or reset the current installation.
    4. Follow the instructions on the remaining pages of the Systems Management Server Setup Wizard.

MORE INFORMATION

If the Modify or reset the current installation option is not available in SMS Setup (Smssetup.exe), you can run SMS Setup from the latest Systems Management Server service pack. For additional information about how to obtain the latest SMS 2.0 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

288239 How to obtain the latest Systems Management Server 2.0 service pack



The Systems Management Server 2.0 Recovery Tools are maintenance and recovery tools that help administrators maintain or restore regular site operations. For additional information about the SMS 2.0 Recovery Tools, visit the following Microsoft Web site:
For additional information about how to perform a site reset and when to use the ACL Reset tool, click the following article number to view the article in the Microsoft Knowledge Base:

263366 Performing a site reset or modification displays server connection account reset message



Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbMgmtServices kbwinservperf ATdownload kbtshoot kbprb KB883988 kbAudITPRO