The main IP address is incorrectly identified as the source of packets that you send through a socket that is bound to a virtual IP address in Windows 2000 (883926)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you send packets from a Microsoft Windows 2000-based computer that has a network card with one main IP address and one virtual IP address through a socket that is bound to the virtual IP address, the main IP address may be unexpectedly identified as the source of the packets. You expect the virtual IP address to be identified as the source of the packets. This problem occurs only if you send the packets to a multicast address.

For example, this problem occurs in the following scenario:
  1. You assign the IP address 150.41.50.56 as the main address for the network card.
  2. You assign the IP address 120.50.10.10 as an additional, or virtual, address for the network card.
  3. You bind socket 12345 to IP address 120.50.10.10.
  4. You send packets through socket 12345 to a multicast address.
The source address of the packets that you sent through socket 12345 to the multicast address is IP 150.41.50.56 instead of IP 120.50.10.10.

CAUSE

This problem occurs because the IP_MULTICAST_IF socket option does not obtain the virtual IP address, and therefore it marks the source of the packets as the main IP address.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows 2000 Server Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ---------------------------------------------------------
   19-Jun-2003  20:05  5.0.2195.6687  120,240  Afd.sys
   19-Jun-2003  20:05  5.0.2195.6602  108,816  Msafd.dll        
   20-Aug-2004  08:06  5.0.2195.6969  318,832  Tcpip.sys
   19-Jun-2003  20:05  5.0.2195.6655   16,240  Tdi.sys
   19-Jun-2003  20:05  5.0.2195.6601   17,680  Wshtcpip.dll   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The IP_MULTICAST_IF socket option determines the interface to be used for multicasting. For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB883926 kbAudITPRO