The W3wp.exe process causes 100% CPU utilization on Management Servers in MOM 2005 (883925)



The information in this article applies to:

  • Microsoft Operations Manager 2005

SYMPTOMS

The W3wp.exe process causes 100% CPU utilization on a Microsoft Operations Manager (MOM) 2005 Management Server in the destination management group. Product connectors that are accessing the MOM Connector Framework may receive the following exception error message:
System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.InvalidOperationException: There was an error generating the XML document. ---> System.ArgumentException: The surrogate pair is invalid.
After these symptoms occur, data is not forwarded from the management group. W3wp.exe is a worker process for Microsoft Internet Information Services (IIS).

CAUSE

This problem occurs if the following conditions are true:
  • A MOM 2005 product connector uses the MOM Connector Framework from multiple management groups.
  • The MOM 2005 product connector is configured to forward discovery data to the destination management group.
  • The W3wp.exe process is running on the MOM Management Server.
Another problem with the MOM Connector Framework occurs if the error message description includes special characters or invalid characters.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Operations Manager 2005. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

905416 How to obtain the latest Microsoft Operations Manager 2005 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next MOM 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix must be applied to each computer that meets all the following criteria:
  • The computer hosts a MOM 2005 Management Server.
  • The computer has the MOM Connector Framework installed.
  • The computer is a member of a destination or source management group.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version  Size     File name
   ----------------------------------------------------------------------
   23-Sep-2004  14:22  1.0.0.0  265,960  Mom2005-rtm-kb883925-x86-enu.exe
   22-Sep-2004  22:19           131,584  Q883925.msp
   20-Sep-2004  19:49            28,089  Readme.rtf
   20-Sep-2004  19:49             7,300  Relnote.htm

Hotfix installation information

To apply this hotfix, follow these steps:
  1. Create a shared folder that the MOM 2005-based servers in your network have access to.
  2. Copy the Mom2005-rtm-kb883925-x86-enu.exe file to the folder that you created in step 1.
  3. On each MOM 2005-based computer that meets the Prerequisites criteria, log on to the computer by using an account that has administrative permissions.
  4. Connect to the shared folder that you created in step 1, and then run the Mom2005-rtm-kb883925-x86-enu.exe file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Operations Manager 2005 Service Pack 1.

MORE INFORMATION

For more information about other problems that are resolved by Microsoft Operations Manager 2005 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

905420 List of bugs that are fixed in Microsoft Operations Manager 2005 service packs

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer ATdownload kbGetSP kbBug kbOpmanInterop kbOpmanAlerts kbOpman2005spfix kbOpman2005bug kbServer kberrmsg kbPerformance kbinterop kbfix KB883925 kbAudITPRO