A Systems Management Server 2.0 client may run an advertised program more than one time (872803)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

When Systems Management Server (SMS) 2.0 advertises a program to an SMS 2.0 client, the client may run the advertised program more than one time, even though it is not scheduled to do this.

CAUSE

This problem occurs when the client cannot correctly compute the next run time. This problem occurs when all the following conditions are true:
  • The Advertised Programs Client Agent is configured to provide a countdown before the scheduled program is run.
  • The After Running properties setting for the advertised program is set to Program restarts computer.
  • When the advertised program runs, the program does not restart the SMS client computer.
  • The advertisement for the program is mandatory and has a repeating schedule.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version              Size  File name
   ------------------------------------------------------------------
   25-Feb-2003  17:35  2.0.1493.5140     238,944  Abnwcli.dll
   26-Feb-2003  00:45  2.0.92.10         383,777  Apasetup.exe
   25-Feb-2003  17:35  2.0.1493.5140     263,008  Bindclin.dll
   26-Feb-2003  00:35  2.0.92.10       1,377,879  Ccmcore.exe
   26-Feb-2003  00:35  2.0.1493.5191   3,498,258  Clicore.exe
   25-Feb-2003  17:55  2.0.1493.5144      90,480  Clisvcl.exe
   26-Feb-2003  00:45                         67  Compverbase.ini
   26-Feb-2003  00:45                         67  Compversmsapm32.ini
   26-Feb-2003  00:45                         67  Compverswdist.ini
   25-Feb-2003  17:15  2.0.1493.5136      35,168  Cqmgr32.dll
   25-Feb-2003  17:35  2.0.1493.5140     161,120  Falclin.dll
   25-Feb-2003  17:35  2.0.1493.5140     340,832  Mslmclin.dll
   25-Feb-2003  17:35  2.0.1493.5140     272,736  Ndsclin.dll
   26-Feb-2003  00:10  2.0.1493.5186      13,168  Ntlg_rem.exe
   26-Feb-2003  00:10  2.0.1493.5186     195,440  Nt_logon.dll
   26-Feb-2003  00:25  2.0.1493.5189      55,664  Odpsys32.exe
   26-Feb-2003  00:25  2.0.1493.5189      61,296  Odpusr32.exe
   26-Feb-2003  00:45  2.0.1493.5193     258,928  Smsapm32.exe
   26-Feb-2003  00:25  2.0.92.10         641,887  Swdist32.exe

Installation instructions

To install this hotfix, follow these steps:
  1. Create a shared folder in a location that is available to all your SMS site servers.
  2. Copy the SMS2.0-SP#-KB872803-X86-ENU.exe hotfix file to the shared folder.

    Note In the hotfix file name, # represents the number of the service pack.
  3. On every SMS 2.0 primary site server and SMS 2.0 secondary site server in your environment, follow these steps:
    1. Log on to the site server using an account with administrative credentials.
    2. Quit the SMS Administrator console if it is running.
    3. Start Windows Explorer.
    4. In Windows Explorer, locate the shared folder that contains the hotfix, double-click the SMS2.0-SP#-KB872803-X86-ENU.exe file, and then follow the instructions in the wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbfix kbBug KB872803 kbAudITPRO