A database transaction log file grows unexpectedly in Microsoft Project Server 2002 and in Microsoft Project Server 2003 (871237)



The information in this article applies to:

  • Microsoft Office Project Server 2003
  • Microsoft Project Server 2002
  • Microsoft Project Web Access

SYMPTOMS

When you use Microsoft Project Web Access or Microsoft Project Professional to log on to Microsoft Office Project Server 2003 or Microsoft Project Server 2002, you may experience one or more of the following symptoms:
  • A very large database transaction log file is created.
  • SQL transactions may not be completed successfully and may start to roll back.
  • SQL transactions may complete very slowly.
  • Performance issues may occur.
  • You receive the following error message:
    Error: 9002, Severity: 17, State: 2
    The log file for database '%.*ls' is full.

CAUSE

These symptoms may occur when a database transaction log is full. The database transaction log may grow quickly because of the many changes that Microsoft Office Project Professional 2003 or Microsoft Project Professional 2002 and Microsoft Project Server 2003 or Microsoft Project Server 2002 record in the transaction log.

RESOLUTION

To resolve this issue, truncate the database transaction log. To do this, follow these steps:
  1. Start SQL Server Enterprise Manager. To do this, click Start, point to All Programs or Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
  2. Expand Microsoft SQL Servers, expand SQL Server Group, expand the appropriate server, and then expand Databases.
  3. Right-click the ProjectServer database, point to All Tasks, and then click Shrink Database.
  4. In the Shrink Database - DatabaseName dialog box, click OK to keep the current values.
To reduce the growth of the database transaction log, follow these steps:
  1. Start SQL Server Enterprise Manager. To do this, click Start, point to All Programs or Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
  2. Expand Microsoft SQL Servers, expand SQL Server Group, expand the appropriate server, and then expand Databases.
  3. Right-click the ProjectServer database, and then click Properties.
  4. Click the Options tab, and then under Recovery, click Simple in the Model box.

    Notes
    • After you set the recovery model to use the Simple option, you cannot restore the database to the point of failure or to a specific point in time.
    • For more information about the recovery options that are available in SQL Server, see the "Recovery Options" Help topic. To do this, follow these steps:
      1. Click Start, point to All Programs or Programs, point to Microsoft SQL Server, and then click Online Books.
      2. Click the Index tab, type recovery options, and then click Display.
      3. In the Setting Database Options topic, locate Recovery Options.
  5. Click the Transaction Log tab, and then do the following:
    1. Click to select the Automatically grow file check box.

      Note The default values will appear in the File growth section.
    2. Click Unrestricted file growth.
  6. Click OK to close the ProjectServer Properties dialog box.
For additional information about the steps to follow when the transaction log of a SQL Server database expands to an unacceptable limit, click the following article number to view the article in the Microsoft Knowledge Base:

873235 How to stop the transaction log of a SQL Server database from growing unexpectedly

MORE INFORMATION

Besides displaying the symptoms that are listed in the "Symptoms" section, SQL Server may mark databases that are suspect because of a lack of disk space for transaction log expansion.

For information about how to recover from this situation, see the "Insufficient Disk Space" topic in the SQL Server Books Online. Visit the following Microsoft Web site to view the SQL Server Books Online:

Modification Type:MajorLast Reviewed:11/18/2004
Keywords:kbtshoot kbprb KB871237 kbAudITPRO kbAudEndUser