BUG: You cannot open a list of saved queries in BizTalk Server 2004 Health and Activity Tracking (HAT) (870956)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition

SYMPTOMS

If at least one .trq file in the folder of saved queries (C:\Program Files\Microsoft BizTalk Server 2004\Tracking\Queries) is an invalid XML file, the following problems may occur:
  • When you click the Queries menu in Health and Activity Tracking (HAT), you may receive an error message that is similar to the following:
    There is an error in XML document (0,0)
  • The HAT error message dialog box gives no information about the invalid file.
  • HAT does not release the reference to the invalid file.
  • When you double-click a .trq file in the saved queries folder that is not a valid XML file, the following problems occur:
    • The error message dialog box does not have an error symbol.
    • The error message dialog box does not have the Health and Activity Tracking title.

CAUSE

This behavior occurs when you click the Queries menu in HAT and the queries folder contains one or more invalid XML files.

RESOLUTION

To resolve this problem, check each XML file in the queries folder to make sure that it is valid.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:8/3/2004
Keywords:kbnofix kbBTSHat kbbug KB870956 kbAudDeveloper kbAudITPRO