Your computer stops responding when you use a smart card to log on to Windows XP (843541)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you enter your smart card personal identification number (PIN) to log on to a computer that is running Microsoft Windows XP, the computer stops responding when the desktop is displayed.

CAUSE

This problem occurs when you replace the Microsoft Graphical Identification and Authentication (GINA) DLL (Msgina.dll) with a third-party Msgina.dll, a custom Msgina.dll, or a pass-through "stub" Msgina.dll. When this Msgina.dll returns WLX_SAS_ACTION_LOCK_WKSTA immediately after the WlxLoggedOutSAS function is called, Winlogon enters a race condition and stops responding.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The P1 version of this P2 has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows XP Service Pack 1
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   21-Aug-2004  18:54  5.1.2600.1579     398,848  Licdll.dll       
   21-Aug-2004  18:34  5.1.2600.1586     482,816  Winlogon.exe
Microsoft Windows XP Service Pack 2
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   21-Aug-2004  18:39  5.1.2600.2508     502,784  Winlogon.exe

To enable this hotfix, you must add the registry entry AlwaysStartSCThread to the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

. This entry takes two values: 1 and 0. To enable this hotfix, you must set AlwaysStartSCThread to 1. To disable this hotfix, you must set AlwaysStartSCThread to 0.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type AlwaysStartSCThread, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 1, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer ATdownload kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug KB843541 kbAudITPRO