Computer stops responding when you shut down Windows 2000 (843540)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you try to shut down your Microsoft Windows 2000-based computer, the computer may become unresponsive or stop responding (hang).

CAUSE

This problem occurs because of a problem in the Openhci.sys driver. The problem may be more likely to occur if you start the computer by using the Physical Address Extension (PAE) switch in the Boot.ini file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows 2000 Service Pack 4

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Jun-2004  21:04  5.0.2195.6940      25,072  Openhci.sys

WORKAROUND

If you are using the PAE switch in the Boot.ini file, you may be able to work around this problem by deleting the PAE switch from the Boot.ini file. To do this, follow these steps:
  1. Start Windows Explorer.
  2. On the Tools menu, click Folder Options.
  3. Click the View tab, click Show hidden files and folders, click to clear the Hide protected operating system files check box, and then click OK. If you receive a warning dialog box, click Yes to continue.
  4. In the root folder, such as the C:\ folder, locate the Boot.ini file, and then delete its read-only attribute.
  5. Open the Boot.ini file, and then delete the /PAE parameter from the Advanced RISC Computing (ARC) path. For example, delete /PAE from the following Windows 2000 Professional entry:

    multi(0)disk(0)rdisk(0)partition(2)\%systemroot%="Windows 2000 Professional"/PAE

  6. On the File menu, click Save.
  7. Restore the read-only attribute to the Boot.ini file.
  8. Restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB843540 kbAudEndUser