A workstation may become the master browser instead of a Windows Server 2003-based member server (843517)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

A computer that provides a workstation role, such as a computer that is running Microsoft Windows 2000 Professional or Microsoft Windows XP Professional, may become the master browser for the Computer Browser service. This behavior may not be what you want if you want a computer that is a member server to be the master browser.

CAUSE

This behavior occurs because workstation computers and member servers have an equal chance to become the master browser during the browser election process. The browser election process determines the master browser for the network segment.

For additional information about the Computer Browser service, click the following article number to view the article in the Microsoft Knowledge Base:

188001 Description of the Microsoft Computer Browser service

Note By default, Windows-based servers that are domain controllers receive preference to become the master browser during a browser election.

RESOLUTION

To resolve this behavior and to give Windows Server 2003-based member servers preference to become the master browser during a browser election, install the following update.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

   
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Jul-2004  02:20  5.2.3790.194      395,264  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194      158,208  Rdbss.sys

Windows Server 2003, 64-Bit Edition


   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Jul-2004  02:20  5.2.3790.194    1,123,328  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194      464,896  Rdbss.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To determine which computer is the master browser, type the following command at a command prompt on your Windows-based server, and then press ENTER:

browstat status


For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB843517 kbAudITPRO