Some programs that convert TIFF documents into PDF documents stop responding on a Windows 2000-based computer (843249)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

After you apply security update 835732, some programs that convert TIFF documents into PDF documents stop responding on a Microsoft Windows 2000-based computer.

CAUSE

This problem occurs because the variable that is used for storing the driver name in the Imgedit.ocx file is not initialized. The Imgedit.ocx file is used by some programs that convert TIFF documents into PDF documents. The driver name variable in the Imgedit.ocx file cannot be initialized because this variable is filled with an address that is inaccessible. This variable is filled with an address that is inaccessible after you apply security update 835732.

Note Before you apply security update 835732, the address in the driver name variable is valid, but it is filled with junk. This variable is checked for validity by the Imgedit.ocx file even though this variable is not used when a TIFF document is converted into a PDF document.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows 2000 Service Pack 3 or Windows 2000 Service Pack 4 is required to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   11-Oct-2004  04:25  5.0.2195.6983  306,448  Imgedit.ocx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about security update 835732, click the following article number to view the article in the Microsoft Knowledge Base:

835732 MS04-011: Security Update for Microsoft Windows

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE kbpubtypekc KB843249 kbAudITPRO kbAudEndUser