Documentation subwindows do not appear in their default locations in Visual Studio .NET, in the MSDN Library, or in the TechNet Viewer (841711)



The information in this article applies to:

  • Microsoft Developer Network (MSDN)
  • Microsoft TechNet

SYMPTOMS

When you randomly move windows, such as the Search Results window or the Index Results window, in a Microsoft Visual Studio .NET documentation window, and then you try to move these windows back to their default locations, you may experience a problem. Additionally, if you close the Visual Studio .NET documentation window, and then you open it again, you may find windows at unexpected locations. The Visual Studio .NET documentation windows are not restored to their default locations.

CAUSE

There is no option that is currently available to lock windows in the locations that you want.

RESOLUTION

To find the default layout of the Visual Studio .NET documentation window, follow these steps:
  1. Close the Visual Studio .NET documentation window.
  2. Locate the Dexplore.xml file in the following folder:

    system drive:\Documents and Settings\user name\Application Data\Microsoft\MSDN\7.0

    Note The system drive placeholder indicates the system drive where the operating system is installed on your computer. The user name placeholder indicates the user name that you are currently logged on to the computer with.
  3. Delete the Dexplore.xml file.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to reproduce the problem

To reproduce the problem, follow these steps:
  1. For Microsoft Visual Studio .NET 2002, click Start, point to Microsoft Visual Studio .NET, and then click Microsoft Visual Studio .NET documentation.

    The Microsoft Visual Studio .NET combined Collection window appears.

    For Microsoft Visual Studio .NET 2003, click Start, point to Microsoft Visual Studio .NET 2003, and then click Microsoft Visual Studio .NET 2003 documentation.

    The Microsoft Visual Studio .NET 2003 combined Collection window appears.
  2. Right-click the title of the Contents window, and then click Floating.
  3. Move the Contents window to another location in the Help window.
  4. Try to return the Contents window to its default location.

    You may notice the problem that is mentioned in the "Symptoms" section.
There are other ways that windows may become disorganized because windows can be docked, hidden, unhidden, and floated. Therefore, you may find other occurrences where you can move a window in the Help window to a different location, and then you cannot move the window back to its original location.

This problem may also occur in other products that use the Dexplore.exe file. The other products include Content Viewer for TechNet and Microsoft Document Explorer 7.0 for Microsoft Developer Network (MSDN) Library.

Modification Type:MajorLast Reviewed:8/11/2004
Keywords:kbXML kbUser kblayout kbhelp kbprb KB841711 kbAudDeveloper