A recipient cannot open a file attachment when an e-mail message is sent to an Exchange Server 5.5 computer (840813)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

SYMPTOMS

When a Microsoft Exchange Server 5.5 computer receives an e-mail message that contains a file attachment, the recipient of the message cannot open the file attachment.

CAUSE

This problem occurs if the file attachment has a long file name and the file name contains double-byte character set (DBCS) characters. When the Exchange Server 5.5 computer extracts the headers from a message that has a file attachment with a long file name that contains DBCS characters, if a header has been folded, the Exchange Server 5.5 computer adds lines to the header. This corrupts the header, and the file attachment cannot be opened by the recipient.

RESOLUTION

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange Server 5.5 Service Pack 4.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-May-2004  04:42  5.5.2658.8        496,400  Mdbmsg.dll       
   10-May-2004  05:24  5.5.2658.8      2,635,024  Store.exe        

WORKAROUND

To work around this problem, the file attachment can be re-sent with a different file name that does not contain DBCS characters.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbExchange550preSP5fix kbBug kbfix kbQFE kbHotfixServer KB840813 kbAudITPRO