SMS 2003 MIF files do not support keywords that are listed as unsupported by the Distributed Management Task Force (840203)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you try to compile a Management Information Format (MIF) file in Microsoft Systems Management Server (SMS) 2003, the SMS_INVENTORY_DATA_LOADER component may report a status message that is similar to the following in the Status Message Viewer:
Compilation failed - Attribute name already used for this group on line xxx
In this case, the classes that are contained in the MIF file are not added to the client architecture. For example, the following MIF file will not compile correctly:
 
Start Component
	Name = Test

	Start Group
		Name = UnsupportedKeyword
		ID = 1
		Class = UnsupportedClass
		Key = 1
   		Start Attribute
    			Name = MyAttibute
    			ID = 1
    			Description = ""
    			Type = Integer
    			Value = unsupported
   		End Attribute
	End Group

CAUSE

This problem typically occurs when you use a keyword that is not supported in the Desktop Management Interface specification. This specification is created by the Distributed Management Task Force (DMTF). After you apply this hotfix, the "unsupported" attributes are skipped, and the Mifprovider.log file contains a message that is similar to the following: An instrumentation symbolic name or an 'unsupported' value is detected for an Attribute "AttributeName" (attribute ID x), it will be skipped.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

When you install this hotfix, the SMS site services stop and restart.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
07-May-2004  22:44  2.50.2726.131     863,464  Sms2003-rtm-kb840203-x86-enu.exe  
07-May-2004  07:25                     13,075  Filemap.ini
20-Feb-2004  09:03  2.0.6.7           355,242  Smsupdate.exe    
25-Dec-2003  02:30  2.50.2726.131      68,608  Mifprov.dll      
06-Aug-2000  00:51  2000.80.194.0     274,489  Ntwdblib.dll     
23-Feb-2003  01:05  2.0.1493.5011     855,312  Preinst.exe      
25-Dec-2003  02:30                    275,456  Sms2003ac-kb840203-x86.msp

Installation information

This hotfix updates the SMS Inventory Agent component to version 2.50.2726.0131. This hotfix contains an Advanced Client update. To apply the hotfix silently, use the /s switch at the command prompt.

You must apply this hotfix at primary and secondary sites. Because of new architecture in SMS 2003, you must create a new package and a new program to advertise this hotfix to the Advanced Client computers. As part of the Setup program, this hotfix can create the package and the advertisement automatically. We recommend that you let the Setup program create the package and the advertisement for you.

To install this hotfix, follow these steps:
  1. Download the hotfix file, and then run the self-extracting executable file to create the Sms2003-rtm-kb840203-x86-enu.exe file.
  2. Copy Sms2003-rtm-kb840203-x86-enu.exe to a folder on your SMS primary or secondary site server computer.
  3. Click Start, point to All Programs, point to Systems Management Server, and then click SMS Administrator Console.
  4. In the SMS Administrator Console, expand Site Database.
  5. Right-click Collections, point to New, and then click Collection.
  6. In the Name box, type Advanced Clients for 840203.
  7. Click the Membership Rules tab, and then click the yellow database button to open Query Rule Properties.
  8. Type a name for the query, and then click Edit Query Statement.
  9. On the General tab, click the Show Query Language button.
  10. Paste or type the following query in the Query statement box:
     select * from SMS_R_System inner join SMS_G_System_SMS_ADVANCED_CLIENT_STATE on 
    
    SMS_G_System_SMS_ADVANCED_CLIENT_STATE.ResourceID = SMS_R_System.ResourceId where SMS_R_System.ClientType = 1 
    
    and SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Name = "SmsInventory" and 
    
    (SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version <( "2.50.2726.0131" or 
    
    SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version in ( "2.50.2726.4", "2.50.2726.5", "2.50.2726.18", "2.50.2726.1", 
    
    "2.50.2726.16" ))
    To use this query, you must have at least one Advanced Client computer in your inventory to create the database classes.
  11. Click OK three times.

    This query identifies management points that have the Advanced Client installed and Advanced Client computers that do not have this hotfix installed.
  12. Run Sms2003-rtm-kb840203-x86-enu.exe on the SMS site server computer.
  13. After the files are copied, click Yes, I want to create a package and program now, and then click Next.
  14. Click Next to accept the default package and the default program name.
  15. Complete the installation wizard.
  16. In the SMS Administrator Console, expand Packages.
  17. Right-click the KB840203 - Advanced Client Hotfix package, point to All Tasks, click Distribute Software, and then click Next.
  18. Click to select the check box for your distribution points, and then click Next.
  19. Click Next to advertise the program.
  20. Click Next to select the program for the advertisement.
  21. Click Advertise this program to an existing collection, and then click Browse.
  22. Click the Advanced Clients for 840203 collection, and then click OK.
  23. Click Next two times.
  24. Click Advertise the program only to members of the specified collection, and then click Next.
  25. Complete the Software Distribution Wizard.
To perform a silent installation of this hotfix, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. Locate the folder that contains the Sms2003-rtm-kb840203-x86-enu.exe file.
  3. Type the following command, and then press ENTER:

    SMS2003-RTM-KB840203-X86-ENU.exe /s

If you cannot install the Advanced Client part of this hotfix, view the Advanced Client log files on the client computer. The Advanced Client log files are in the %systemroot%\System32\Ccmsetup and the %systemroot%\System32\Ccm\Logs folders.

Note This hotfix updates the SMS 2003 Advanced Client. For more information about the SMS 2003 Standard Client version of this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

843219 You notice an unusual number of MIF files in the Badmifs folder, and some SMS client inventory information is missing in Systems Management Server 2003

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more informationabout standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about the Desktop Management Interface specification, visit the following Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbtshoot kbSMSTopazFix kbfix kbBug KB840203 kbAudITPRO