Problems occur when you connect to a Novell NetWare server from a computer that is running Client Service for NetWare and Either Windows 2000 Professional or Windows XP (840049)



The information in this article applies to:

  • Microsoft Windows 2000 Professional
  • Microsoft Windows XP Professional

SYMPTOMS

When you connect to a Novell NetWare server from a computer that is running Client Services for NetWare (CSNW) and either Microsoft Windows 2000 Professional or Microsoft Windows XP Professional, you may experience one or more of the following symptoms:
  • Programs may not run as expected.
  • Saved data may be corrupted.
  • Your connection may stop unexpectedly.
When you use the Whoami tool on the Windows-based computer, the reported connection number may be different from the expected connection number.

CAUSE

This problem may occur if you have more than 255 connections to the NetWare server at the same time. When a connection is made to a NetWare server by a Client Services for NetWare client after 255 connections are made to the NetWare server, the connection numbers are counted again starting at 0. Two clients may have the same connection number.

For example, when the 270th user logs on to the NetWare server, the user is identified as connection number 14. Connection number 14 is also used by the 14th user to log on to NetWare. When the 270th user logs off from the NetWare server, the 14th user may also be disconnected from the NetWare server. Any data that is entered by the 270th user is actually owned by the 14th user.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows 2000 Hotfix

   Date         Time   Version        Size     File name
   ---------------------------------------------------------
   05-Apr-2004  18:51  5.0.2195.6920  161,072  Nwrdr.sys
   06-Apr-2004  00:04                   7,342  Kb840049.cat

Windows XP Hotfix

   Date         Time   Version        Size     File name
   ---------------------------------------------------------
   17-May-2004  17:46  5.1.2600.1533     156,800  Nwrdr.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New naming schema for Microsoft Windows hotfix packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWin2000preSP5fix KB840049 kbAudITPRO