A scheduled backup task unexpectedly quits in Windows Server 2003 when the backup tape is full (839591)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you schedule a backup by using the Windows Backup program in Microsoft Windows Server 2003, Windows Backup unexpectedly quits when the backup tape is full. Additionally, if you view the backup log file, the following information is displayed:

The requested media failed to mount. The operation was aborted.

You expect Windows Backup to prompt you to insert an additional tape and to then complete the backup operation.

CAUSE

This problem occurs if the following conditions are true:
  • You schedule an unattended backup on a stand-alone tape device.
  • The tape device requires more than one tape to complete the backup operation.
This problem occurs because of a design change in Windows Server 2003. In Microsoft Windows 2000, Windows Backup prompts you for an additional tape when the first tape is full. However, in Windows Server 2003, you are no longer prompted to insert an additional tape during an unattended backup operation. This change was made because, frequently, no user is available to insert an additional tape during an unattended backup operation.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003 64-bit editions
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   07-Sep-2004  23:29  5.2.3790.209    3,342,848  Ntbackup.exe     IA-64
Windows Server 2003 32-bit editions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   07-Sep-2004  22:27  5.2.3790.209    1,171,968  Ntbackup.exe   

Hotfix installation information

After you install this hotfix, a new /UP switch is available for use in Windows Backup scripts. When you specify the /UP switch in your backup script, Windows Backup prompts you to insert an additional tape during the backup job.

Note The /UP switch is case-sensitive. You must type this switch in uppercase characters.

The following is an example backup script that illustrates how to use the /UP switch:

C:\WINDOWS\system32\ntbackup.exe backup "@C:\Documents and Settings\Administrator.TESTSERVER\Local Settings\Application Data\Microsoft\Windows NT\NTBackup\data\Test.bks" /v:no /r:no /rs:no /hc:on /m normal /j "Test" /l:s /p "4mm DDS" /um /UP

WORKAROUND

To work around this problem, install a tape library to work with your stand-alone tape device.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB839591 kbAudITPRO