"The Internet Connection Wizard was interrupted because of an error or user intervention" error message when you run the Internet Connection Wizard (839494)



The information in this article applies to:

  • Microsoft Small Business Server 2000

SYMPTOMS

When you run the Internet Connection Wizard (ICW) to configure the Microsoft Internet Security and Acceleration (ISA) Server firewall settings, you may receive an error message that is similar to the following:
The Internet Connection Wizard was interrupted because of an error or user intervention. Details have been recorded in the file Icwlog.txt, which can be found in the C:\Program Files\Microsoft BackOffice\Support directory. Would you like to cancel this action?

Click Yes to exit the wizard and restore your pre-wizard settings.
Click No to proceed with the wizard and configure any remaining components.
Click Cancel to close the wizard immediately without restoring your pre-wizard settings.
When you open the Icwlog.txt file, you may receive the following error message. The error message appears at or near the bottom of the file:
calling StartWebProxyService (0x8007041c).
Error 0x8007041c returned from call to CCometCommit::Commit().
Note The specified path, C:\Program Files\Microsoft BackOffice\Support, is the default path for a typical installation. The actual path that is referenced in the error message is the one that the server uses if it differs from the default.

Additionally, the following error messages may be logged in the Event Viewer:Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7024
Description: The Microsoft Web Proxy service terminated with service-specific error 2147942402. Event Type: Error
Event Source: Microsoft Web Proxy
Event Category: None
Event ID: 14127
Description: The Web Proxy service could not initialize [error code]. The internal error code in the Data area of the event properties indicates the cause of the failure. Event Type: Error
Event Source: Microsoft Web Proxy
Event Category: None
Event ID: 11000
Description: Microsoft Web Proxy failed to start. The failure occurred during Reading publishing rules because the configuration property of the key SOFTWARE\Microsoft\Fpc\Arrays\{A3B65577-1118-410F-A7F2-6C36E405AAB4}\PolicyElements\ Client-Sets\{972E8EA1-C204-4C58-9BC4-2C89C45810B5} could not be accessed. Use the source location 2.546.3.0.1200.166 to report the failure. The error code in the Data area of the event properties indicates the cause of the failure. For more information about this event, see ISA Server Help. The error description is: The system cannot find the file specified.

CAUSE

This behavior occurs if an ISA Server Policy Element that is referenced in an ISA Server Rule is deleted.

Note When you delete a policy element in the ISA Management console, the Confirm Delete prompt includes a Verify that no rules use this element check box. If you click to clear this check box, and then click Yes to delete the element, ISA will delete the policy element without checking whether any rules are using the element.

RESOLUTION

To resolve this behavior, disable the ISA Server Rule. To do so, follow these steps:
  1. Click Start, point to Programs, point to Microsoft ISA Server, and then click ISA Management.
  2. In the left pane, expand Servers and Arrays, and then expand Publishing.
  3. Click Web Publishing Rules, and then view the list of rules in the right pane.

    Note Any ISA server rule that has a missing policy element will display three question marks (???) in the column that corresponds to the missing policy element. For example, a Web publishing rule that applies to a deleted client address set displays ??? in the Applies to column.
  4. If ??? does not appear in Web Publishing Rules, click one of the following folders, and then view the list of rules in the right pane to find the ISA server rule with the missing policy element:
    • Server Publishing Rules
    • Site and Content Rules
    • Protocol Rules
    Note Expand Access Policy to locate Site and Content Rules and Protocol Rules.
  5. Right-click the ISA server rule that has ??? displayed in the column that corresponds to the missing policy element, and then click Disable.

Modification Type:MajorLast Reviewed:4/29/2004
Keywords:kbprb KB839494 kbAudEndUser kbAudITPRO