When you open an account and then try to add a new record in Microsoft CRM 1.0, you receive a syntax error message, or an access violation occurs (839434)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft Business Solutions CRM 1.0
  • Microsoft Business Solutions CRM 1.0

SYMPTOMS

In Microsoft Business Solutions CRM 1.0, you open an account and then try to add a new record, such as a sub-account, a contact, or an opportunity. In this scenario, you receive a syntax error message, or an access violation occurs.

CAUSE

This problem occurs if a custom picklist field is added to Microsoft CRM 1.0 and if the custom picklist includes values that contain a percent character (%).

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version of Microsoft Business Solutions CRM that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on computers that are running Microsoft CRM 1.0 Client or Microsoft CRM 1.0 Server.

Prerequisites

To install this update, Microsoft CRM version 1.0 must be installed.

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Microsoft CRM 1.0 Sales for Outlook client

Date         Time   Version       Size     File name
-------------------------------------------------------
26-Mar-2004  00:00  1.0.3017.101  166,608  Crmcache.dll

Server

Date         Time   Version       Size     File name
-------------------------------------------------------
26-Mar-2004  00:00  1.0.3017.101  166,608  Crmcache.dll

Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbMBSMigrate kbQFE kbHotfixServer KB839434 kbAudITPRO kbAudEndUser