Multiple Web-based programs or Component Object Model-based programs stop responding on a computer that is running Windows Server 2003 or Windows 2000 (839229)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you start multiple Web-based programs or Component Object Model-based programs, some of the programs may stop responding for 30 seconds. After 30 seconds, you may receive the following error message:
**** Activation Hard Delay Detected!!!*******

CAUSE

This problem occurs when the programs are running on a computer that has dual processors and that is running Microsoft Windows Server 2003 or Microsoft Windows 2000. A race condition is created when the programs try to access the same resource and one or more of the programs cannot access the resource.

RESOLUTION

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, x86 build
   Date         Time   Version            Size  File name
   ----------------------------------------------------------
   30-Jul-2004  00:09  5.2.3790.196  2,407,424  Ntkrnlmp.exe
   29-Jul-2004  23:40  5.2.3790.196  2,064,896  Ntkrnlpa.exe     
   29-Jul-2004  23:40  5.2.3790.196  2,108,928  Ntkrpamp.exe
   30-Jul-2004  00:18  5.2.3790.196  2,207,744  Ntoskrnl.exe     
   30-Jul-2004  00:13  5.2.3790.196  1,813,504  Win32k.sys
Windows Server 2003, IA-64 build
   Date         Time   Version            Size  File name     Platform
   -------------------------------------------------------------------
   29-Jul-2004  21:02  5.2.3790.196  5,604,864  Ntkrnlmp.exe  IA-64
   29-Jul-2004  20:46  5.2.3790.196  4,954,624  Win32k.sys

Windows 2000 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6824      42,256  Basesrv.dll      
   21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe          
   19-Jun-2003  20:05  5.0.2195.6660     233,744  Gdi32.dll        
   24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
   24-Mar-2004  02:17  5.0.2195.6824      54,544  Mpr.dll          
   10-Jul-2004  22:37  5.0.2195.6958     335,120  Msgina.dll       
   24-Mar-2004  02:17  5.0.2195.6892      90,264  Rdpwd.sys
   24-Mar-2004  02:17  5.0.2195.6897     403,216  User32.dll       
   05-Aug-2003  22:14  5.0.2195.6794     385,808  Userenv.dll      
   10-Jul-2004  05:36  5.0.2195.6958   1,631,760  Win32k.sys
   11-Mar-2004  02:37  5.0.2195.6898     181,520  Winlogon.exe     
   25-Sep-2003  18:08  5.0.2195.6826     243,984  Winsrv.dll       
   24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
   10-Jul-2004  05:36  5.0.2195.6958   1,631,760  Win32k.sys
   25-Sep-2003  18:08  5.0.2195.6826     243,984  Winsrv.dll       

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003preSP1fix kbDownload kbCOMServices kbComCtrls kbBug kbfix kbWin2000preSP5fix KB839229