You receive a "0x80041001 - Generic failure" error message when you query SMS_Program in Systems Management Server 2003 (837387)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

If you query the Windows Management Instrumentation (WMI) SMS_Program class in Systems Management Server (SMS) 2003, you may receive an error message that is similar to the following error message:
Error
Number: 0x80041001
Facility: WMI
Description: Generic failure
This error occurs if you use a Visual Basic script (VBS) or the wbemtest tool to query the class.

Additionally, if you try to use the SMS Administrator Console to create a new advertisement, programs that are associated with the package that you want to advertise may not appear in the Program drop-down menu, and the following error is logged to the Smsprov.log file:
E:\TOPAZ\sdk_provider\nt\smsprov\SspObjectQuery.cpp(4313) : Query failed.

CAUSE

This problem may occur if you have applied instance security rights to one or more SMS packages.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name    Platform
   -------------------------------------------------------------------
   25-Dec-2003  10:55  2.50.2726.123  4,444,160  Smsprov.dll  x86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

Installation information

The hotfix installer

Note This method is only for Intel-based computers.

To use the hotfix installer to install this hotfix, follow these steps:
  1. Create a folder in a location that your SMS site servers can use.
  2. Copy the SMS2003-RTM-KB837387-X86-ENU.exe update file to the new folder.
  3. From each of the primary SMS site servers in your environment, use an account that has administrative credentials to log on to your site server.
  4. Quit the SMS Administrator console if it is running.
  5. Run the SMS2003-RTM-KB837387-X86-ENU.exe file, and then follow the instructions in the wizard.

Manual installation

How to manually install the hotfix to the SMS site serverTo manually install the hotfix to the SMS site server, follow these steps:
  1. Create a folder in a location that your SMS site servers can use.
  2. Run the following command:

    SMS2003-RTM-KB837387-X86-ENU.exe /x

    Extract the hotfixed files to the folder that you created.
  3. From each of the primary SMS site servers in your environment, use an account that has administrative credentials to log on to your site server.
  4. Quit the SMS administrator console.
  5. Stop all SMS services.
  6. Stop the WMI service.
  7. In the SmsRootFolder\bin\Platform folder, run the following command:

    regsvr32 /u Smsprov.dll

  8. Copy the updated Smsprov.dll file from the disk or network share to the SmsRootFolder\bin\Platform folder.
  9. In the SmsRootFolder\bin\Platform folder, run the following command:

    regsvr32 Smsprov.dll

  10. Restart the WMI service.
  11. Restart the SMS services.
How to manually install the hotfix to a remote SMS Provider serverTo manually install the hotfix to a remote SMS Provider server, follow these steps:
  1. At the SMS Provider server, stop all SMS services and the WMI service.
  2. In the SmsRootFolder\bin\Platform folder, run the following command:

    regsvr32 /u Smsprov.dll

  3. Replace the Smsprov.dll file in the SmsRootFolder\bin\Platform folder with the version from the hotfix.
  4. In the SmsRootFolder\bin\Platform folder, run the following command:

    regsvr32 Smsprov.dll

  5. Restart the WMI service and all SMS services at the SMS Provider server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE KB837387