You receive a "The system cannot change your password now because the domain <DomainName> is not available" error message when you try to change your password in Windows XP or in Windows 2000 (837327)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4

SYMPTOMS

When you try to change your password in Microsoft Windows XP or in Microsoft Windows 2000 on a locked-out account that has the User must change password at next logon attribute set, you receive an error message that is similar to the following:
The system cannot change your password now because the domain <DomainName> is not available.
Note In this error message, DomainName is a placeholder for the actual domain name.

CAUSE

This problem occurs because the account is missing its default service principal name (SPN).

RESOLUTION

To resolve this problem, log on as a local Administrator and then apply the hotfix that is mentioned in the following article:

324141 Changing the password on a locked-out account generates a "Domain not available" message



If you cannot resolve this problem by applying the hotfix, log on as a local Administrator and then follow these steps.

Microsoft Windows 2000 Server, Windows 2000 Professional, and Windows 2000 Advanced Server

  1. On the desktop, right-click My Computer, and then click Properties.
  2. Click the Network Identification tab, and then click Properties.
  3. Click More, and then click to select the Change primary DNS suffix when domain membership changes check box.
  4. Click OK four times.
  5. When you are prompted to restart your computer, click Yes.

Microsoft Windows XP Professional

  1. On the desktop, right-click My Computer, and then click Properties.
  2. Click the Computer Name tab, and then click Change.
  3. Click More, and then click to select the Change primary DNS suffix when domain membership changes check box.
  4. Click OK four times.
  5. When you are prompted to restart your computer, click Yes.

Modification Type:MinorLast Reviewed:11/4/2004
Keywords:kbActiveDirectory kbwinservds kbprb KB837327 kbAudEndUser kbAudITPRO