A "Stop 0x7F" error message occurs intermittently when you access a storage device in Windows 2000 (836760)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Advanced Server
SYMPTOMS
You may intermittently receive a "Stop 0x7F" error message while your computer is accessing a storage device. The first Stop parameter is 0x00000000. This parameter indicates a divide by zero error.
CAUSE
This problem is caused by a divide by zero error that occurs when a DIV instruction is executed, and the divisor is zero. Memory corruption, hardware problems, or software failures can cause this problem. In this case, if the BytesPerSector value of the disk geometry is not initialized correctly, a BytesPerSector value of zero may be passed when the PartitionTable information is requested. This scenario causes the divide by zero error.
RESOLUTIONHotfix informationA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem. To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. PrerequisitesMicrosoft Windows 2000 Service Pack 3 or Service Pack 4 Restart requirementYou must restart your computer after you apply this hotfix. Hotfix replacement informationThis hotfix does not replace any other hotfixes. File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
--------------------------------------------------------------
16-Jan-2004 00:18 5.0.2195.6891 35,632 Classpnp.sys
24-Feb-2004 05:10 5.0.2195.6901 30,864 Disk.sys
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Modification Type: | Minor | Last Reviewed: | 10/28/2005 |
---|
Keywords: | kbHotfixServer kbQFE kberrmsg kbBug kbfix kbQFE kbWin2000preSP5fix KB836760 kbAudEndUser |
---|
|