Copied security roles do not inherit the same privileges as the original role, and new roles may generate error messages in Microsoft CRM. (835555)



The information in this article applies to:

  • Microsoft Business Solutions CRM 1.0

CRM SE:652CRM SE:562CRM SE:773

SYMPTOMS

After you copy a security role in Microsoft Business Solutions CRM 1.0, the new role does not inherit the same privileges as the original role. Alternatively, you may receive error messages in the event log of the Microsoft CRM server after you create a new security role.

You may also receive one of the following messages in the event log of the Microsoft CRM server:

Event message 1

MSCRMSecurity Service
Event ID:6148
Error: Some security descriptors could not be adjusted after a privilege change. -2147205110 (0x80044005)
Description: <description> Invalid code for CRM error </description>
<details> Connection failure SQL State - 08501, Native error -0 </details> <file>&:\crm\build\3017\src\platform\include\OMCommon\dataccess.inl </file>
<line> 324 </line>

Event message 2

MSCRMSecurity Service
Event ID:6148
Error: Some security descriptors could not be adjusted after a privilege change. -2147024809 (0x80070057)
Description: The parameter is incorrect.

Event message 3

MSCRMSecurity Service
Event ID:6148
Error: Some security descriptors could not be adjusted after a privilege change. -2147463168 (0x80005000)
Description: <could not load message>
Comments: GetRoleSids() failed:%dAdditionally, users who are assigned one of the new or copied roles may not be able to log on to the Microsoft CRM server. These users may also receive one of the following error messages:

Error message 1

Access Denied "User has not been granted any licenses or the user has not been assigned any roles."

Error message 2

License Error "The selected user or user trying to log on has not been assigned a security role or license, and does not have sufficient privileges for this action. For more information, contact your system administrator."
Users of Microsoft CRM may also receive the following error message when they try to perform an action, even though their roles should let them perform the action:
The selected user does not have sufficient privileges for this action.

CAUSE

This problem may occur if one of the following conditions is true:
  • You create or copy a Microsoft CRM role in an environment that has a slow instance of Microsoft SQL Server.
  • The Microsoft CRM databases contain hundreds of thousands of records or millions of records.
The role-creation operations and the copy operations update every record in Microsoft CRM that contains a security descriptor. The security descriptor contains information about the access privileges that Microsoft CRM users have for that record. These privileges are based on the Microsoft CRM roles that have been assigned to the users.

RESOLUTION

There is a hotfix for this problem. The hotfix is part of a cumulative package. For additional information about the cumulative package that contains this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

835308 A copy operation may fail when you try to copy a role in Microsoft CRM 1.0

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

835292 Copying a role does not work in Microsoft Business Solutions CRM version 1.2


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbMBSadministration kbQFE kbMBSMigrate KB835555 kbAudITPRO kbAudKnowledgeWorker kbAudEndUser