The SMS 2003 Administrator Console stops responding when you connect to a SMS 2.0 site server (834812)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you use a Microsoft Systems Management Server (SMS) 2003 Administrator Console to administer a SMS 2003 site and a SMS 2.0 site in the same Microsoft Management Console (MMC) snap-in, the SMS Administrator Console may stop responding when you try to expand the SMS 2.0 site. The Adminui.log file may have an error message that is similar to the following:
Error: Possible UI connection error code is -2147217406
Error: Possible UI connection error code is -2147217406
Error: Attempt to reconnect but no connection namespace provided
Error: Possible UI connection error code is -2147217400

CAUSE

This problem occurs when you use the SMS 2003 Administrator Console to connect to the SMS 2.0 site server. The SMS 2003 Administrator Console uses the GetObject function to try to determine the version of the site server that you connected to. In the SMS 2003 Administrator Console, the GetObject function specifies a class that only applies to SMS 2003. When you connect to a SMS 2.0 site server, the GetObject class query may return the 0x80041002 error code. The GetObject function parses the Uiconnections.ini file, logs the error in the Adminui.log file, and then tries to reconnect to the SMS 2.0 site server. However, the connection may not be correctly released.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
06-Aug-2000  12:51  2000.80.194.0     274,489  Ntwdblib.dll     
23-Feb-2003  13:05  2.0.1493.5011     855,312  Preinst.exe      
25-Dec-2003  12:55  2.50.2726.111   1,421,312  Sms_base.dll

International Client Pack

Date         Time   Version            Size    File name
--------------------------------------------------------------
06-Aug-2000  12:51  2000.80.194.0     274,489  Ntwdblib.dll     
23-Feb-2003  13:05  2.0.1493.5011     855,312  Preinst.exe      
25-Dec-2003  12:55  2.50.2726.111   1,421,312  Sms_base.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbfix kbBug KB834812 kbAudITPRO