You receive an "Error 792" error message and you cannot connect to a node in a Windows Server 2003 Network Load Balancing cluster by using a VPN connection in Windows XP (833976)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003

SYMPTOMS

When you try to connect to a Microsoft Windows Server 2003 Network Load Balancing cluster by using a virtual private network (VPN) connection, you may temporarily not be able to connect to a node in the server cluster. You may receive the following error message:
Error 792
The following event may be logged to the Windows Server 2003 Network Load Balancing server event log: Event Type: Failure Audit
Event ID: 547
Description:
IKE security association negotiation failed.

CAUSE

This problem may occur after you run the wlbs.exe drainstop command on a node in the Microsoft Windows Server 2003 Network Load Balancing cluster.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   25-Mar-2004  01:50  5.1.2600.1331     183,808  Gptext.dll       
   25-Mar-2004  01:38  5.1.2600.1347      74,240  Ipsec.sys
   10-Jan-2004  12:32  5.1.2600.1331      98,304  Ipseccmd.exe     
   25-Mar-2004  01:50  5.1.2600.1331     334,848  Ipsecsnp.dll     
   25-Mar-2004  01:50  5.1.2600.1331     159,744  Ipsecsvc.dll     
   25-Mar-2004  01:50  5.1.2600.1331     364,544  Ipsmsnap.dll     
   25-Mar-2004  01:50  5.1.2600.1366     827,904  Oakley.dll       
   25-Mar-2004  01:50  5.1.2600.1331      98,304  Polstore.dll     
   25-Mar-2004  01:50  5.1.2600.1331     163,840  Rasmans.dll      
   25-Mar-2004  01:50  5.1.2600.1331      29,184  Winipsec.dll

Windows XP 64-Bit Edition

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   25-Mar-2004  17:12  5.1.2600.1331     510,976  Gptext.dll       
   18-Feb-2004  18:07  5.1.2600.1347     257,920  Ipsec.sys
   25-Mar-2004  17:12  5.1.2600.1331     891,904  Ipsecsnp.dll    
   25-Mar-2004  17:12  5.1.2600.1331     504,320  Ipsecsvc.dll    
   25-Mar-2004  17:12  5.1.2600.1331   1,225,728  Ipsmsnap.dll    
   25-Mar-2004  17:12  5.1.2600.1366     574,464  Oakley.dll      
   25-Mar-2004  17:12  5.1.2600.1331     317,952  Polstore.dll     
   25-Mar-2004  17:12  5.1.2600.1331     490,496  Rasmans.dll     
   25-Mar-2004  17:12  5.1.2600.1331      87,040  Winipsec.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB833976 kbAudITPRO kbAudEndUser