An Office 2003 program is slow or may appear to stop responding (hang) when you open a file from a network location (833041)



The information in this article applies to:

  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to open a file from a network location in one of the Microsoft Office 2003 programs listed in the "Applies To" section of this article, the Office program may run very slowly or may appear to stop responding (hang).

CAUSE

This behavior may occur if the connection to the network location is lost during the time that your Office program is opening the file.

WORKAROUND

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To work around this behavior, add the EnableShellDataCaching value to the Microsoft Windows registry.

To do this, follow these steps:
  1. Close your Office 2003 programs.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

  5. After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
  6. Type EnableShellDataCaching, and then press ENTER.
  7. Right-click EnableShellDataCaching, and then click Modify.
  8. In the Value data box, type 1, and then click OK.

    Note Any non-zero number in the Value data box will turn on caching. A zero number or blank (default) will turn off caching.
  9. On the File menu, click Exit to quit Registry Editor.

MORE INFORMATION

This situation may occur after you click Open in the Open dialog box (on the File menu, click Open) to open a file from a network location (for example, a network server). During the process of opening the file, you lose your network connection or the network location that contains the file that you are trying to open goes down. During the process of opening the file, your Office program tries to add the file name and the path information of the file that you are trying to open to the Windows recent file list. Because the network location (path) does not now exist, the Office program may run slowly and may appear to stop responding (hang).

Note This situation may also occur if your connection to your network is slow because your Office program has to make multiple queries to the network to obtain the correct file information.

Modification Type:MajorLast Reviewed:3/23/2006
Keywords:kbRegistry kbnetwork kbopenfile kbprb KB833041 kbAudEndUser kbAudITPRO