You receive an "Access Violation (0xC0000005 exception)" error in Internet Explorer 6.0 (832823)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows NT 4.0

SYMPTOMS

Microsoft Internet Explorer 6.0 stops responding when you try to open an HTML document or a Web page. Additionally, you receive the following error message:
Access Violation (0xC0000005 exception)

CAUSE

This problem may occur when you use Internet Explorer 6.0 to open an HTML document or a Web page that contains SPAN tags. If a SPAN tag is not closed correctly by using the </SPAN> tag, an access violation may occur.

The <SPAN> tag is an inline element that renders text by using a style sheet. The tag is typically used to change the style of an element or of a block of text.

<SPAN> tags are also used to group inline elements in an HTML document. For example, the following HTML document may cause an access violation because the </SPAN> tag is missing.
<html>
  <body>
      <style type="text/css">
        #three
          {
          position: absolute;
          }
        #one #two
          {
          position: absolute;
          }
      </style>

      <div id="one">
        In 'one'
        <SPAN id="two">
          In 'two'

-> The </SPAN> tag is missing 

      </div>

      <div id="three">
        In 'three'
      </div>
  </body>
</html>

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Internet Explorer 6.0 SP1 for Windows Server 2003 x86

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   27-Oct-2004  00:40  6.0.3790.227    2,925,056  Mshtml.dll       


Internet Explorer 6.0 SP1 for Windows Server 2003 IA-64

   Date         Time   Version            Size    File name
   -------------------------------------------------------------------
   27-Oct-2004  01:43  6.0.3790.227    8,230,912  Mshtml.dll     IA-64
   27-Oct-2004  01:40  6.0.3790.227    2,925,056  Wmshtml.dll    x86


Internet Explorer 6.0 SP1

   Date         Time    Version            Size      File name
   --------------------------------------------------------------
   17-Jun-2004  00:01   6.0.2800.1449    2,692,096   Mshtml.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:11/1/2005
Keywords:kbHotfixServer kbQFE kbQFE kbIE600sp2fix kbfix kbbug kbIE600preSP2fix kbprb KB832823 kbAudEndUser